summary refs log tree commit diff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-05-10 04:13:00 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-05-10 04:15:21 +0200
commit8297f01ee0094005c1d40923f605360a15030628 (patch)
tree9983d56e9cf414690fc496ddba568a9f579591d4 /gnu/packages/android.scm
parentf546fcb4f96b2ecf0d51f50589b3f5976723905d (diff)
downloadguix-8297f01ee0094005c1d40923f605360a15030628.tar.gz
gnu: fastboot: Simplify package.
* gnu/packages/android.scm (fastboot)[source]: Use android-platform-system-core.
[arguments]<#:phases>[unpack]: Remove.
<#:phases>[enter-source]: Modify.
<#:phases>[patch-source]: New phase.
[native-inputs]: Remove core, extras.
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm23
1 files changed, 8 insertions, 15 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 812898c8ac..d09cd635e5 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -586,25 +586,20 @@ Android core.")
   (package
     (name "fastboot")
     (version (android-platform-version))
-    (source #f)
+    (source (android-platform-system-core version))
     (build-system android-ndk-build-system)
     (arguments
      `(#:make-flags (list "CXXFLAGS=-std=gnu++11")
        #:phases
        (modify-phases %standard-phases
-         (replace 'unpack
-           (lambda* (#:key inputs #:allow-other-keys)
-             (mkdir-p "core")
-             (with-directory-excursion "core"
-               (invoke "tar" "axf" (assoc-ref inputs "core") "--strip-components=1")
-               (substitute* "fastboot/Android.mk"
-                (("libext4_utils_host") "libext4_utils_host libselinux libpcre")))
-             (copy-recursively (assoc-ref inputs "extras") "extras"
-                               #:keep-mtime? #t)
-             #t))
          (add-after 'unpack 'enter-source
            (lambda _
-             (chdir "core/fastboot")
+             (chdir "fastboot")
+             #t))
+         (add-after 'enter-source 'patch-source
+           (lambda _
+             (substitute* "Android.mk"
+              (("libext4_utils_host") "libext4_utils_host libselinux libpcre"))
              #t))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
@@ -629,9 +624,7 @@ Android core.")
        ("mkbootimg" ,mkbootimg)
        ("zlib" ,zlib)))
     (native-inputs
-     `(("core" ,(android-platform-system-core version))
-       ("extras" ,(android-platform-system-extras version))
-       ("xz" ,xz)))
+     `(("xz" ,xz)))
     (home-page "https://developer.android.com/studio/command-line/")
     (synopsis "Android image flasher")
     (description