summary refs log tree commit diff
path: root/gnu/packages/animation.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-08-27 10:54:41 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-31 18:00:17 +0800
commit5078e98cf3d09e761d60e51eb3fbae88ea3d12f3 (patch)
tree2bff53ff69395748b25e711e3881aa8f2834c20f /gnu/packages/animation.scm
parentd6966b8a5b4f2ddda2bc685b9642e7a1c2cbe17c (diff)
downloadguix-5078e98cf3d09e761d60e51eb3fbae88ea3d12f3.tar.gz
gnu: pencil2d: Fix tests.
* gnu/packages/animation.scm (pencil2d)[arguments]: Use gexps.
Add fix-tests phase.
Diffstat (limited to 'gnu/packages/animation.scm')
-rw-r--r--gnu/packages/animation.scm31
1 files changed, 18 insertions, 13 deletions
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index 9691dd0d80..d6bd3fd03d 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -442,19 +442,24 @@ waveform until they line up with the proper sounds.")
     (inputs
      (list qtbase-5 qtxmlpatterns qtmultimedia-5 qtsvg-5))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (invoke "qmake" (string-append "PREFIX=" out)))))
-         (add-after 'install 'wrap-executable
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out"))
-                   (plugin-path (getenv "QT_PLUGIN_PATH")))
-               (wrap-program (string-append out "/bin/pencil2d")
-                 `("QT_PLUGIN_PATH" ":" prefix (,plugin-path)))
-               #t))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-tests
+            (lambda _
+              ;; Its bundled catch2-2.5.0 fails to build with glibc-2.35.
+              (copy-file #$(file-append catch2 "/include/catch2/catch.hpp")
+                         "tests/src/catch.hpp")))
+          (replace 'configure
+            (lambda* (#:key inputs outputs #:allow-other-keys)
+              (let ((out (assoc-ref outputs "out")))
+                (invoke "qmake" (string-append "PREFIX=" out)))))
+          (add-after 'install 'wrap-executable
+            (lambda* (#:key inputs outputs #:allow-other-keys)
+              (let ((out (assoc-ref outputs "out"))
+                    (plugin-path (getenv "QT_PLUGIN_PATH")))
+                (wrap-program (string-append out "/bin/pencil2d")
+                  `("QT_PLUGIN_PATH" ":" prefix (,plugin-path)))))))))
     (home-page "https://www.pencil2d.org")
     (synopsis "Make 2D hand-drawn animations")
     (description