summary refs log tree commit diff
path: root/gnu/packages/animation.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-30 23:56:29 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-31 08:27:45 +0200
commitae44ebb90e2abf4867c6ae24556e3129a3069816 (patch)
tree07145d176063a86854c74d9820a5581e4a5ba2ab /gnu/packages/animation.scm
parentb0415c0361606d8d43cdc0841ad9cf74e1079861 (diff)
downloadguix-ae44ebb90e2abf4867c6ae24556e3129a3069816.tar.gz
gnu: synfigstudio: Fix crash on opening files.
* gnu/packages/animation.scm (synfigstudio)[arguments]: Add "wrap-program"
phase.
Diffstat (limited to 'gnu/packages/animation.scm')
-rw-r--r--gnu/packages/animation.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index cbbfa6ed4a..3c590950fd 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -147,8 +147,21 @@ for tweening, preventing the need to hand-draw each frame.")
               (patches
                (search-patches "synfigstudio-fix-ui-with-gtk3.patch"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; This fixes the file chooser crash that happens with GTK 3.
+         (add-after 'install 'wrap-program
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (gtk (assoc-ref inputs "gtk+"))
+                    (gtk-share (string-append gtk "/share")))
+               (wrap-program (string-append out "/bin/synfigstudio")
+                 `("XDG_DATA_DIRS" ":" prefix (,gtk-share)))
+               #t))))))
     (inputs
      `(("gtkmm" ,gtkmm)
+       ("gtk+" ,gtk+)
        ("libsigc++" ,libsigc++)
        ("synfig" ,synfig)))
     (native-inputs