summary refs log tree commit diff
path: root/gnu/packages/animation.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-13 04:12:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-14 20:15:29 +0200
commit05f6b03217bdb8d024b5d29b50fdec74413a312e (patch)
tree6f93eb75ca0cf9f7f2c9752f374b68a937b2cbec /gnu/packages/animation.scm
parent36c8f1f1e629b0d1cd33647385e222880b6c3286 (diff)
downloadguix-05f6b03217bdb8d024b5d29b50fdec74413a312e.tar.gz
gnu: synfig, synfigstudio: Update to 1.2.2.
* gnu/packages/animation.scm (synfig-version): New variable.
(etl)[version]: Use it.
(synfig)[version]: Likewise.
[source]: Update to 1.2.2.
[native-inputs]: Add intltool.
(synfigstudio)[version]: Use SYNFIG-VERSION.
[source]: Update to 1.2.2.  Remove obsolete patch.
* gnu/packages/patches/synfigstudio-fix-ui-with-gtk3.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/animation.scm')
-rw-r--r--gnu/packages/animation.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index 97c5e6c615..b46382c035 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -41,13 +41,15 @@
   #:use-module (gnu packages qt)
   #:use-module (gnu packages video))
 
+;; ETL, synfig, and Synfig Studio are updated in tandem.
+(define synfig-version "1.2.2")
+
 (define-public etl
   (package
     (name "etl")
-    (version "1.2.2")
+    (version synfig-version)
     (source (origin
               (method url-fetch)
-              ;; Keep this synchronized with the synfig release version.
               (uri (string-append "mirror://sourceforge/synfig/releases/"
                                   version "/source/ETL-" version ".tar.gz"))
               (sha256
@@ -65,7 +67,7 @@ C++ @dfn{Standard Template Library} (STL).")
 (define-public synfig
   (package
     (name "synfig")
-    (version "1.2.0")
+    (version synfig-version)
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/synfig/releases/"
@@ -73,7 +75,7 @@ C++ @dfn{Standard Template Library} (STL).")
                                   ".tar.gz"))
               (sha256
                (base32
-                "1gqx4gn4c73rqwhsgzx0a460gr9hadmi28csp75rx30qavqsj7k1"))))
+                "1vy27kl68sbg41sfasa58k3p2nc1xfalvzk3k9gich9h90rpnpsz"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
@@ -131,7 +133,8 @@ C++ @dfn{Standard Template Library} (STL).")
        ("openexr" ,openexr)
        ("pango" ,pango)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
     (home-page "https://www.synfig.org")
     (synopsis "Vector-based 2D animation renderer")
     (description
@@ -143,7 +146,7 @@ for tweening, preventing the need to hand-draw each frame.")
 (define-public synfigstudio
   (package
     (name "synfigstudio")
-    (version "1.2.0")
+    (version synfig-version)
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/synfig/releases/"
@@ -151,16 +154,14 @@ for tweening, preventing the need to hand-draw each frame.")
                                   ".tar.gz"))
               (sha256
                (base32
-                "0fbckfbw8dzf0m2wv7vlmw492k1dqa3zf510z019d0as3zpnp6qm"))
+                "1ql92kh9z8w2j9yi3pr7hn7wh2r2j35xynwv9xlwyd7niackgykn"))
               (modules '((guix build utils)))
               (snippet
                '(begin
                   (substitute* "src/synfigapp/pluginmanager.cpp"
                     (("xmlpp::Node\\* n =")    "const xmlpp::Node* n =")
                     (("xmlpp::Node::NodeList") "xmlpp::Node::const_NodeList"))
-                  #t))
-              (patches
-               (search-patches "synfigstudio-fix-ui-with-gtk3.patch"))))
+                  #t))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases