summary refs log tree commit diff
path: root/gnu/packages/animation.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 15:33:28 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-27 12:46:39 +0200
commit6023fa366db309202181e696f6aeee1d64ec331f (patch)
tree33d05a27cd03f513479e24008781cd3deff6d41a /gnu/packages/animation.scm
parent6ac59f45ff376e5e8fab4f1cd5c64333e53e4e10 (diff)
downloadguix-6023fa366db309202181e696f6aeee1d64ec331f.tar.gz
gnu: papagayo: Return #t from all phases.
* gnu/packages/animation.scm (papagayo)[arguments]: Substitute INVOKE
for SYSTEM*.
Diffstat (limited to 'gnu/packages/animation.scm')
-rw-r--r--gnu/packages/animation.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index 22af707401..a10747ef38 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -226,10 +227,10 @@ contains the graphical user interface for synfig.")
                                    "\nLIBS +=" libsndfile
                                    "/lib/libsndfile.so\n"
                                    "win32 {"))))
-               (zero? (system* "qmake"
-                               (string-append "DESTDIR="
-                                              (assoc-ref outputs "out")
-                                              "/bin")))))
+               (invoke "qmake"
+                       (string-append "DESTDIR="
+                                      (assoc-ref outputs "out")
+                                      "/bin"))))
            ;; Ensure that all required Qt plugins are found at runtime.
            (add-after 'install 'wrap-executable
              (lambda* (#:key inputs outputs #:allow-other-keys)