summary refs log tree commit diff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-01-28 21:15:04 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-01-29 10:54:17 +0100
commitc21ad767d4368dbd9ff37a6fd5cdea8aa37fec57 (patch)
treec218f784efdcdfcb48a39c507279b0c66cbe4ac6 /gnu/packages/astronomy.scm
parentb54523ad32c9c61108c6c099e22ce017feb78934 (diff)
downloadguix-c21ad767d4368dbd9ff37a6fd5cdea8aa37fec57.tar.gz
gnu: Add stuff.
* gnu/packages/astronomy.scm (stuff): New variable.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 58fefa04a0..c22bfb8709 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -306,6 +306,27 @@ can be used to control telescopes over a serial port for tracking celestial
 objects.")
     (license license:gpl2+)))
 
+(define-public stuff
+  (package
+    (name "stuff")
+    (version "1.26.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.astromatic.net/download/stuff/"
+                           "stuff-" version ".tar.gz"))
+       (sha256
+        (base32 "1syibi3b86z9pikhicvkkmgxm916j732fdiw0agw0lq6z13fdcjm"))))
+    (build-system gnu-build-system)
+    (home-page "https://www.astromatic.net/software/stuff")
+    (synopsis "Astronomical catalogue simulation")
+    (description
+     "Stuff is a program that simulates \"perfect\" astronomical catalogues.
+It generates object lists in ASCII which can read by the SkyMaker program to
+produce realistic astronomical fields.  Stuff is part of the EFIGI development
+project.")
+    (license license:gpl3+)))
+
 (define-public celestia
   (let ((commit "9dbdf29c4ac3d20afb2d9a80d3dff241ecf81dce"))
     (package