summary refs log tree commit diff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-19 15:15:17 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-30 22:06:32 +0100
commitb607cc9130e620eb0782c3fbf7b3c5c258f3b5fa (patch)
tree80131b4165edc01b57fbfdcee80d3da11a33b9ce /gnu/packages/astronomy.scm
parent213eae66c7a288ca8293065a95297c2df885454d (diff)
downloadguix-b607cc9130e620eb0782c3fbf7b3c5c258f3b5fa.tar.gz
gnu: Add webbpsf-data.
* gnu/packages/astronomy.scm (webbpsf-data): New variable.

Change-Id: I8b9836053f81187e2367a943ac981906880856b9
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 7e69584127..28180aa533 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -6438,6 +6438,29 @@ the image to position on the sky.  Auxillary programs search star catalogs and
 manipulate images.")
     (license license:gpl2+)))
 
+(define-public webbpsf-data
+  (package
+    (name "webbpsf-data")
+    (version "1.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       ;; 70.1MiB archive
+       (uri "https://stsci.box.com/shared/static/qxpiaxsjwo15ml6m4pkhtk36c9jgj70k.gz")
+       (file-name (string-append "webbpsf-data-" version ".tar.gz"))
+       (sha256
+        (base32 "0b3qxp6mrm2dwsdnqnprf4yrp0zbncknildqmf28wgginwa5sch8"))))
+    (build-system copy-build-system)
+    (arguments
+     (list
+      #:install-plan #~'(("." "share/webbpsf-data"))))
+    (home-page "https://webbpsf.readthedocs.io/en/stable/installation.html")
+    (synopsis "JWST pupil shape, instrument throughputs, and aperture positions data files")
+    (description
+     "This package contains FIT and CSV files requried for WebbPSF
+installation and distributed separatly from it.")
+    (license license:bsd-3)))
+
 (define-public weightwatcher
   (package
     (name "weightwatcher")