summary refs log tree commit diff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-11-07 23:06:56 +0000
committerChristopher Baines <mail@cbaines.net>2022-11-21 14:25:13 +0000
commit4d05c5fa57fe768e4d2ed760fa3aee05d72becb5 (patch)
treec9584a34214e7d06a7139e1ca46d3a50fe99629a /gnu/packages/astronomy.scm
parentf77ff092d34ed3a40a75eb1bcc5628f99299bca9 (diff)
downloadguix-4d05c5fa57fe768e4d2ed760fa3aee05d72becb5.tar.gz
gnu: python-gwcs: Update to 0.18.2.
* gnu/packages/astronomy.scm (python-gwcs): Fix build and update to 0.18.2.
[build-system]: Use pyproject-build-system.
[arguments]: Remove redundant.
[native-inputs]: Use python-jsonschema-next over python-jsonschema to fix
tests failing to run due to python-asdf issue with low version of jsonschema,
see https://github.com/asdf-format/asdf/pull/1203.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm16
1 files changed, 4 insertions, 12 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 3c53d4aeea..b37aeacc70 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2264,24 +2264,16 @@ install an implementation package such as gwcs.")
 (define-public python-gwcs
   (package
     (name "python-gwcs")
-    (version "0.18.0")
+    (version "0.18.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "gwcs" version))
        (sha256
-        (base32 "194j49m8xjjzv9pp8cnj06igz8sdxb0nphyybcc7mhigw0f0kr30"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "python" "-m" "pytest")))))))
+        (base32 "0v9qcq6zl74d6s882s6xmas144jfalvll6va8rvrxmvpx4vqjzhg"))))
+    (build-system pyproject-build-system)
     (native-inputs
-     (list python-jsonschema
+     (list python-jsonschema-next
            python-jmespath
            python-pytest
            python-pytest-doctestplus