summary refs log tree commit diff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-02-19 10:13:02 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-19 11:05:33 +0100
commitd1bd22b9fb17e94931b7ebe23c6d9735b195442a (patch)
tree56a7203ffe5a3a3bbb95fa9752af2fd551d1cd72 /gnu/packages/astronomy.scm
parent56ec8d6281b072e14d0442b6a55b1c315f9015cb (diff)
downloadguix-d1bd22b9fb17e94931b7ebe23c6d9735b195442a.tar.gz
gnu: Add python-sep.
* gnu/packages/astronomy.scm (python-sep): New variable.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 3d12a87f8a..98ef7b3a7e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -816,6 +816,31 @@ Astronomical Union (IAU).  All C routines are wrapped as Numpy universal
 functions, so that they can be called with scalar or array inputs.")
     (license license:bsd-3)))
 
+(define-public python-sep
+  (package
+    (name "python-sep")
+    (version "1.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sep" version))
+       (sha256
+        (base32 "0wxdqn92q1grv8k7xi7h88ac6wnznw4xh5bdlz1vz6za2dgsyj4m"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("cython" ,python-cython)
+       ("pytest" ,python-pytest)))
+    (inputs
+     `(("numpy" ,python-numpy)))
+    (home-page "https://github.com/kbarbary/sep")
+    (synopsis "Astronomical source extraction and photometry library")
+    (description
+     "SEP makes the core algorithms of Source Extractor available as a library
+of stand-alone functions and classes.")
+    (license (list license:bsd-3
+                   license:expat
+                   license:lgpl3+))))
+
 (define-public python-skyfield
   (package
     (name "python-skyfield")