summary refs log tree commit diff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-02-19 10:00:56 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-19 11:05:33 +0100
commit4fac8b8f9bcc6742ea148ffcd52bd3cdbc746e16 (patch)
tree25c54e4fc59ce95be32e1fb7d1109d39f54ef55e /gnu/packages/astronomy.scm
parentc1563fc116584cec517c9f5c866c661d3e7cec4e (diff)
downloadguix-4fac8b8f9bcc6742ea148ffcd52bd3cdbc746e16.tar.gz
gnu: Add erfa.
* gnu/packages/astronomy.scm (erfa): New variable.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 9f6b102af7..09ac9e0157 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -113,6 +113,32 @@ in FITS files.")
 for reading and writing.")
     (license license:gpl2+)))
 
+(define-public erfa
+  (package
+    (name "erfa")
+    (version "1.7.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/liberfa/erfa")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1vsqwvzlk7r8q7nwyb7i710blcfdl5kwcm2va9km07a820nsp84a"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("automake" ,automake)
+       ("autoreconf" ,autoconf)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/liberfa/erfa")
+    (synopsis "Essential Routines for Fundamental Astronomy")
+    (description
+     "ERFA is a C library containing key algorithms for astronomy, and is based
+on the SOFA library published by the International Astronomical Union (IAU).")
+    (license license:bsd-3)))
+
 (define-public eye
   (package
     (name "eye")