summary refs log tree commit diff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-01-25 17:43:03 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-01-26 10:04:19 +0100
commit51418c32d95d8188d8877616829f26479f1135c6 (patch)
tree7a81cd422b6b489f2653b8c9f937ec9a6f098522 /gnu/packages/astronomy.scm
parent582bc6a8778b14e8fd2d57aed9c6c96684b1b4db (diff)
downloadguix-51418c32d95d8188d8877616829f26479f1135c6.tar.gz
gnu: Add eye.
* gnu/packages/astronomy.scm (eye): New variable.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 45d62cd855..775a937907 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -88,6 +88,29 @@ in FITS files.")
     (license (license:non-copyleft "file://License.txt"
                           "See License.txt in the distribution."))))
 
+(define-public eye
+  (package
+    (name "eye")
+    (version "1.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.astromatic.net/download/eye/"
+                           "eye-" version ".tar.gz"))
+       (sha256
+        (base32 "092qhzcbrkcfidbx4bv9wz42w297n80jk7a6kwyi9a3fjfz81d7k"))))
+    (build-system gnu-build-system)
+    (home-page "https://www.astromatic.net/software/eye")
+    (synopsis "Small image feature detector using machine learning")
+    (description
+     "In EyE (Enhance Your Extraction) an artificial neural network connected to
+pixels of a moving window (retina) is trained to associate these input stimuli
+to the corresponding response in one or several output image(s).  The resulting
+filter can be loaded in SExtractor to operate complex, wildly non-linear filters
+on astronomical images.  Typical applications of EyE include adaptive filtering,
+feature detection and cosmetic corrections.")
+    (license license:cecill)))
+
 (define-public wcslib
   (package
     (name "wcslib")