summary refs log tree commit diff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-02-07 23:38:58 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-19 11:05:33 +0100
commit8fa76b836ddc651ff3ca3637af27a5c977af367d (patch)
tree3187548df37ddb6594ee2d8f99ed047b6e20bf18 /gnu/packages/astronomy.scm
parent74acb300a34cc19a10e72d7d7f67635ef59b8eb7 (diff)
downloadguix-8fa76b836ddc651ff3ca3637af27a5c977af367d.tar.gz
gnu: Add python-skyfield.
* gnu/packages/astronomy.scm (python-skyfield): New variable.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 07dee4b462..c239a02f3b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -48,6 +48,8 @@
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages pretty-print)
+  #:use-module (gnu packages python-crypto)
+  #:use-module (gnu packages python-science)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages version-control)
@@ -726,3 +728,30 @@ more.")
      "The package is a Python implementation of the mathematics that standard
 JPL ephemerides use to predict raw (x,y,z) planetary positions.")
     (license license:expat)))
+
+(define-public python-skyfield
+  (package
+    (name "python-skyfield")
+    (version "1.36")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "skyfield" version))
+       (sha256
+        (base32 "1dm1327a4qv3klj9blrvddbhl72v1fqz52ym9km8qjj9vdkpywh6"))))
+    (build-system python-build-system)
+    (arguments
+     ;; NOTE: (Sharlatan-20210207T163305+0000): tests depend on custom test
+     ;; framework https://github.com/brandon-rhodes/assay
+     `(#:tests? #f))
+    (inputs
+     `(("certifi" ,python-certifi)
+       ("jplephem" ,python-jplephem)
+       ("numpy" ,python-numpy)
+       ("sgp4" ,python-sgp4)))
+    (home-page "https://rhodesmill.org/skyfield/")
+    (synopsis "Astronomy for Python")
+    (description
+     "Skyfield computes positions for the stars, planets, and satellites in
+orbit around the Earth.")
+    (license license:expat)))