summary refs log tree commit diff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorJuliana Sims <jtsims@protonmail.com>2022-07-03 21:29:58 +0000
committerEfraim Flashner <efraim@flashner.co.il>2022-07-06 11:15:36 +0300
commit8bea879715b5acb24a260dd204f80f206cae07d6 (patch)
tree139d2a88de999f9c23b0c24843a38ca125fd3e57 /gnu/packages/audio.scm
parent3eeeaa26aa40a552a0bf23882aeaf07ca8ddaa20 (diff)
downloadguix-8bea879715b5acb24a260dd204f80f206cae07d6.tar.gz
gnu: qpwgraph: Add qpwgraph.
* gnu/packages/audio.scm (qpwgraph): Add qpwgraph.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e0e1554100..0922c74788 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -37,6 +37,7 @@
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
 ;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
+;;; Copyright © 2022 Juliana Sims <jtsims@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5747,3 +5748,33 @@ source and extracts a 24-bit high resolution WAV file.  It handles both DST
 and DSD streams.")
    (home-page "https://tari.in/www/software/odio-sacd/")
    (license license:gpl3+)))
+
+(define-public qpwgraph
+  (package
+    (name "qpwgraph")
+    (version "0.3.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.freedesktop.org/rncbc/qpwgraph")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1zja4klvzbfwi14ihiahl8zm869h0c1yrpfkzvixxjcps372hh07"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f))    ;; no tests
+    (inputs (list alsa-lib
+                  pipewire-0.3
+                  ;; qtsvg is still on version 5; use qtbase-5 to match
+                  qtbase-5
+                  qtsvg))
+    (native-inputs (list pkg-config))
+    (synopsis "PipeWire graph manager")
+    (description
+     "qpwgraph is a graph manager dedicated to PipeWire, using the Qt C++
+framework.  It provides a visual interface to audio and video connections
+managed by PipeWire.")
+    (home-page "https://gitlab.freedesktop.org/rncbc/qpwgraph")
+    (license license:gpl2)))