summary refs log tree commit diff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 19:59:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 22:00:24 +0200
commit0d0252e45768b2a638a6b018735aab30d27d22ee (patch)
tree76588368a8ddeca357fca474567e30b89a69d52d /gnu/packages/audio.scm
parent1bf919701f878868b018eb567e5c26d81b761d59 (diff)
downloadguix-0d0252e45768b2a638a6b018735aab30d27d22ee.tar.gz
gnu: Use HTTPS for drobilla.net URIs.
* gnu/packages/audio.scm (jalv, lilv, patchage, raul, raul-devel)
(sratom, suil)[source, home-page]: Use HTTPS.
* gnu/packages/gtk.scm (ganv, ganv-devel)[source, home-page]: Likewise.
* gnu/packages/music.scm (ingen)[source, home-page]: Likewise.
* gnu/packages/rdf.scm (serd, sord)[source, home-page]: Likewise.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index ab16707ee5..986a429a0b 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1476,7 +1476,7 @@ synchronous execution of all clients, and low latency operation.")
     (version "1.6.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://download.drobilla.net/jalv-"
+              (uri (string-append "https://download.drobilla.net/jalv-"
                                   version ".tar.bz2"))
               (sha256
                (base32
@@ -1501,7 +1501,7 @@ synchronous execution of all clients, and low latency operation.")
        ("jack" ,jack-1)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
-    (home-page "http://drobilla.net/software/jalv/")
+    (home-page "https://drobilla.net/software/jalv/")
     (synopsis "Simple LV2 host for JACK")
     (description
      "Jalv is a simple but fully featured LV2 host for JACK.  It runs LV2
@@ -1711,7 +1711,7 @@ included are the command line utilities @code{send_osc} and @code{dump_osc}.")
     (version "0.24.2")
     (source (origin
              (method url-fetch)
-             (uri (string-append "http://download.drobilla.net/lilv-"
+             (uri (string-append "https://download.drobilla.net/lilv-"
                                  version ".tar.bz2"))
              (sha256
               (base32
@@ -1737,7 +1737,7 @@ included are the command line utilities @code{send_osc} and @code{dump_osc}.")
      `(("lv2" ,lv2)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
-    (home-page "http://drobilla.net/software/lilv/")
+    (home-page "https://drobilla.net/software/lilv/")
     (synopsis "Library to simplify use of LV2 plugins in applications")
     (description
      "Lilv is a C library to make the use of LV2 plugins as simple as possible
@@ -1966,7 +1966,7 @@ buffers, and audio capture.")
     (version "1.0.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://download.drobilla.net/patchage-"
+              (uri (string-append "https://download.drobilla.net/patchage-"
                                   version
                                   ".tar.bz2"))
               (sha256
@@ -1984,7 +1984,7 @@ buffers, and audio capture.")
        ("dbus-glib" ,dbus-glib)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
-    (home-page "http://drobilla.net/software/patchage/")
+    (home-page "https://drobilla.net/software/patchage/")
     (synopsis "Modular patch bay for audio and MIDI systems")
     (description
      "Patchage is a modular patch bay for audio and MIDI systems based on JACK
@@ -2163,7 +2163,7 @@ using GuixSD.")
     (version "0.8.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://download.drobilla.net/raul-"
+              (uri (string-append "https://download.drobilla.net/raul-"
                                   version ".tar.bz2"))
               (sha256
                (base32
@@ -2177,7 +2177,7 @@ using GuixSD.")
        ("boost" ,boost)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
-    (home-page "http://drobilla.net/software/raul/")
+    (home-page "https://drobilla.net/software/raul/")
     (synopsis "Real-time audio utility library")
     (description
      "Raul (Real-time Audio Utility Library) is a C++ utility library primarily
@@ -2194,7 +2194,7 @@ aimed at audio/musical applications.")
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
-                      (url "http://git.drobilla.net/raul.git")
+                      (url "https://git.drobilla.net/raul.git")
                       (commit commit)))
                 (file-name (string-append name "-" version "-checkout"))
                 (sha256
@@ -2287,7 +2287,7 @@ input/output.")
     (version "0.6.0")
     (source (origin
              (method url-fetch)
-             (uri (string-append "http://download.drobilla.net/sratom-"
+             (uri (string-append "https://download.drobilla.net/sratom-"
                                  version ".tar.bz2"))
              (sha256
               (base32
@@ -2300,7 +2300,7 @@ input/output.")
        ("sord" ,sord)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
-    (home-page "http://drobilla.net/software/sratom/")
+    (home-page "https://drobilla.net/software/sratom/")
     (synopsis "Library for serialising LV2 atoms to/from RDF")
     (description
      "Sratom is a library for serialising LV2 atoms to/from RDF, particularly
@@ -2313,7 +2313,7 @@ the Turtle syntax.")
     (version "0.10.0")
     (source (origin
              (method url-fetch)
-             (uri (string-append "http://download.drobilla.net/suil-"
+             (uri (string-append "https://download.drobilla.net/suil-"
                                  version ".tar.bz2"))
              (sha256
               (base32
@@ -2330,7 +2330,7 @@ the Turtle syntax.")
        ("qt" ,qtbase)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
-    (home-page "http://drobilla.net/software/suil/")
+    (home-page "https://drobilla.net/software/suil/")
     (synopsis "Library for loading and wrapping LV2 plugin UIs")
     (description
      "Suil is a lightweight C library for loading and wrapping LV2 plugin UIs.