summary refs log tree commit diff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2018-05-28 15:02:28 +0200
committerClément Lassieur <clement@lassieur.org>2018-05-28 22:49:55 +0200
commit77cc8778a39426a786217896ec589c8c9341aa8f (patch)
tree0ede337bc64dfc7451f7ed70f4fb3623723f08df /gnu/packages/audio.scm
parentc7d901c130cc1d711d152d9f2930488fe6858d07 (diff)
downloadguix-77cc8778a39426a786217896ec589c8c9341aa8f.tar.gz
gnu: supercollider: Remove broken Qt dependency.
As suggested by Ricardo Wurmus.

This also removes IDE support.

* gnu/packages/audio.scm (supercollider)[arguments]: Add "-DSC_QT=off" to
configure flags.
[native-inputs]: Remove QTTOOLS.
[inputs]: Remove QTBASE, QTWEBKIT, QTSENSORS, QTDECLARATIVE and QTLOCATION.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index a0f21d4dac..97e2a49f6a 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -12,6 +12,7 @@
 ;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2018 okapi <okapi@firemail.cc>
 ;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2064,6 +2065,7 @@ background file post-processing.")
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags '("-DSYSTEM_BOOST=on" "-DSYSTEM_YAMLCPP=on"
+                           "-DSC_QT=off"
                            "-DSC_EL=off") ;scel is packaged individually as
                                           ;emacs-scel.
        #:modules ((guix build utils)
@@ -2124,8 +2126,7 @@ set(YAMLCPP_INCLUDE_DIR ${CMAKE_SOURCE_DIR}/\
 external_libraries/yaml-cpp/include)"))
              #t)))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("qttools" ,qttools)))
+     `(("pkg-config" ,pkg-config)))
     (inputs
      `(("jack" ,jack-1)
        ("libsndfile" ,libsndfile)
@@ -2138,12 +2139,7 @@ external_libraries/yaml-cpp/include)"))
        ("icu4c" ,icu4c)
        ("boost" ,boost)
        ("boost-sync" ,boost-sync)
-       ("yaml-cpp" ,yaml-cpp)
-       ("qtbase" ,qtbase)               ;IDE support
-       ("qtwebkit" ,qtwebkit)
-       ("qtsensors" ,qtsensors)
-       ("qtdeclarative" ,qtdeclarative)
-       ("qtlocation" ,qtlocation)))
+       ("yaml-cpp" ,yaml-cpp)))
     (home-page "https://github.com/supercollider/supercollider")
     (synopsis "Synthesis engine and programming language")
     (description "SuperCollider is a synthesis engine (@code{scsynth} or