summary refs log tree commit diff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-05 19:51:02 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-09 22:57:43 +0100
commitf2fac35953fa14606d426a1bc42b0a0a238926a6 (patch)
treefb2da800fe949ec08a05f6c349772aa62e9f4e8b /gnu/packages/audio.scm
parent8c0b5a75ad8855c011d5ee57ab134f3a03c8fd1b (diff)
downloadguix-f2fac35953fa14606d426a1bc42b0a0a238926a6.tar.gz
gnu: Move 'openal' to (gnu packages audio).
* gnu/packages/games.scm (openal): Removed variable.
* gnu/packages/audio.scm (openal): New variable.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 6e8e2e3ebb..e9e924a836 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -713,6 +713,35 @@ extensions into easy to use C++ classes.  It is the successor of
 lv2-c++-tools.")
     (license license:gpl3+)))
 
+(define-public openal
+  (package
+    (name "openal")
+    (version "1.15.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://kcat.strangesoft.net/openal-releases/openal-soft-"
+                    version ".tar.bz2"))
+              (sha256
+               (base32
+                "0mmhdqiyb3c9dzvxspm8h2v8jibhi8pfjxnf6m0wn744y1ia2a8f"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f)) ; no check target
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("pulseaudio" ,pulseaudio)))
+    (synopsis "3D audio API")
+    (description
+     "OpenAL provides capabilities for playing audio in a virtual 3D
+environment.  Distance attenuation, doppler shift, and directional sound
+emitters are among the features handled by the API.  More advanced effects,
+including air absorption, occlusion, and environmental reverb, are available
+through the EFX extension.  It also facilitates streaming audio, multi-channel
+buffers, and audio capture.")
+    (home-page "http://kcat.strangesoft.net/openal.html")
+    (license license:lgpl2.0+)))
+
 (define-public patchage
   (package
     (name "patchage")