summary refs log tree commit diff
path: root/gnu/packages/authentication.scm
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2020-11-10 16:10:17 +0100
committerLeo Famulari <leo@famulari.name>2020-11-10 21:19:03 -0500
commit29cf85b85793724aa0f1de2b5cda7f70cdb1752f (patch)
tree6c4e9355377eb9400dc0d9cc977677fe8e0ee7f6 /gnu/packages/authentication.scm
parentfbf3f47f854549c060352281714f6e674901feb9 (diff)
downloadguix-29cf85b85793724aa0f1de2b5cda7f70cdb1752f.tar.gz
gnu: oath-toolkit: Update to 2.6.3.
* gnu/packages/authentication.scm (oath-toolkit): Update to 2.6.3.
[source]: Remove obsolete patches.
* gnu/packages/patches/oath-toolkit-glibc-compat.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/authentication.scm')
-rw-r--r--gnu/packages/authentication.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/authentication.scm b/gnu/packages/authentication.scm
index b3ff912c8f..52ab445775 100644
--- a/gnu/packages/authentication.scm
+++ b/gnu/packages/authentication.scm
@@ -33,26 +33,14 @@
 (define-public oath-toolkit
   (package
     (name "oath-toolkit")
-    (version "2.6.2")
+    (version "2.6.3")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://download.savannah.nongnu.org/releases/"
                            name "/" name "-" version ".tar.gz"))
-       (patches
-        (append (search-patches "oath-toolkit-glibc-compat.patch")
-                (list (origin
-                        ;; This huge commit updates gnulib for GCC 7 compatibility.
-                        (method url-fetch)
-                        (uri (string-append
-                              "https://gitlab.com/oath-toolkit/oath-toolkit/commit/"
-                              "2fffce2a471f74a585939c84cce16ef3015e5d3d.diff"))
-                        (file-name "oath-toolkit-update-gnulib.patch")
-                        (sha256
-                         (base32
-                          "088c9s4ay1b54bjqc4mwfs5l3f6357zj5vpw771zlq5g4addd4s0"))))))
        (sha256
-        (base32 "182ah8vfbg0yhv6mh1b6ap944d0na6x7lpfkwkmzb6jl9gx4cd5h"))))
+        (base32 "1cjial8njck2sd7452jcxspbi5h5fnp3n8v3wbmlw8fzqmgzvxx1"))))
     (build-system gnu-build-system)
     (arguments
      ;; TODO ‘--enable-pskc’ causes xmlsec-related test suite failures.