summary refs log tree commit diff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-26 21:10:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-28 22:01:10 +0300
commita81ac55a68110b2c703e79f835fec010b0b3fb8c (patch)
tree5d5de839621b125f665f3676d804fa6e30a4b852 /gnu/packages/autotools.scm
parentf9eac6a7bc14e03361a27ba56cce9261f6bfa0cf (diff)
downloadguix-a81ac55a68110b2c703e79f835fec010b0b3fb8c.tar.gz
gnu: libtool: Remove input labels.
* gnu/packages/autotools.scm (libtool)[native-inputs]: Remove input
labels.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 9d4e7718d2..2a514268d5 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -462,14 +462,15 @@ Makefile, simplifying the entire process for the developer.")
               (patches (search-patches "libtool-skip-tests2.patch"))))
     (build-system gnu-build-system)
     (propagated-inputs (list m4))
-    (native-inputs `(("m4" ,m4)
-                     ("perl" ,perl)
-                     ;; XXX: this shouldn't be necessary, but without it test
-                     ;; 102 fails because it cannot find ltdl/libltdl.la.
-                     ("libltdl" ,libltdl)
-                     ("help2man" ,help2man) ;because we modify ltmain.sh
-                     ("automake" ,automake)      ;some tests rely on 'aclocal'
-                     ("autoconf" ,autoconf-wrapper))) ;others on 'autom4te'
+    (native-inputs
+     (list m4
+           perl
+           ;; XXX: this shouldn't be necessary, but without it test
+           ;; 102 fails because it cannot find ltdl/libltdl.la.
+           libltdl
+           help2man             ; because we modify ltmain.sh
+           automake             ; some tests rely on 'aclocal'
+           autoconf-wrapper))   ; others on 'autom4te'
 
     (arguments
      `(;; Libltdl is provided as a separate package, so don't install it here.