summary refs log tree commit diff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-15 12:02:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-15 12:02:04 +0100
commit2b4e5568508a85c47b602580a6b6930f3bf8bdec (patch)
tree4504bb763ef0369cc8ec786d4297c5149e7147f3 /gnu/packages/autotools.scm
parentd57888a819dae65ef923cb5c92eb15375a2f3f9f (diff)
downloadguix-2b4e5568508a85c47b602580a6b6930f3bf8bdec.tar.gz
gnu: libtool: Add libltdl to native-inputs.
* gnu/packages/autotools.scm (libtool)[native-inputs]: Add libltdl to fix one
failing test.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index e02de1ae81..4a16a12c9b 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2017 ng0 <ng0@infotropique.org>
 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -339,6 +340,9 @@ Makefile, simplifying the entire process for the developer.")
     (propagated-inputs `(("m4" ,m4)))
     (native-inputs `(("m4" ,m4)
                      ("perl" ,perl)
+                     ;; XXX: this shouldn't be necessary, but without it test
+                     ;; 102 fails because it cannot find ltdl/libltdl.la.
+                     ("libltdl" ,libltdl)
                      ("help2man" ,help2man) ;because we modify ltmain.sh
                      ("automake" ,automake)      ;some tests rely on 'aclocal'
                      ("autoconf" ,autoconf-wrapper))) ;others on 'autom4te'