summary refs log tree commit diff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-12-08 22:28:00 +0100
committerLudovic Courtès <ludo@gnu.org>2020-12-08 22:28:00 +0100
commit4a9873529758f07869aede8057099a0f23144f8b (patch)
tree4a70eb59e85a866fe95d53e78b881acf90976788 /gnu/packages/autotools.scm
parente9edaf3639ecf9d4fdaf7901d60a87c582be1c44 (diff)
downloadguix-4a9873529758f07869aede8057099a0f23144f8b.tar.gz
gnu: autotools: Add version 2.70.
* gnu/packages/autotools.scm (autoconf): Rename to...
(autoconf-2.69): ... this.
(autoconf): Define as an alias for AUTOCONF-2.69.
(autoconf-2.70): New variable.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 775576ff5d..203f1bfb52 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -43,7 +43,7 @@
   #:use-module (ice-9 match)
   #:export (autoconf-wrapper))
 
-(define-public autoconf
+(define-public autoconf-2.69
   (package
     (name "autoconf")
     (version "2.69")
@@ -103,6 +103,39 @@ scripts are self-contained and portable, freeing the user from needing to
 know anything about Autoconf or M4.")
     (license gpl3+))) ; some files are under GPLv2+
 
+(define-public autoconf-2.70
+  (package
+    (inherit autoconf-2.69)
+    (version "2.70")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://gnu/autoconf/autoconf-"
+                           version ".tar.xz"))
+       (sha256
+        (base32
+         "1ipckz0wr2mvhj9n3ys54fmf2aksin6bhqvzl304bn6rc1w257ps"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments autoconf-2.69)
+       ((#:tests? _ #f)
+        ;; FIXME: To run the test suite, fix all the instances where scripts
+        ;; generates "#! /bin/sh" shebangs.
+        #f)
+       ((#:phases phases '%standard-phases)
+        `(modify-phases ,phases
+           (add-before 'check 'prepare-tests
+             (lambda _
+               (for-each patch-shebang
+                         (append (find-files "tests"
+                                             (lambda (file stat)
+                                               (executable-file? file)))
+                                 (find-files "bin"
+                                             (lambda (file stat)
+                                               (executable-file? file)))))
+               #t))))))))
+
+(define-public autoconf autoconf-2.69)
+
 (define-public autoconf-2.68
   (package (inherit autoconf)
     (version "2.68")