summary refs log tree commit diff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-06 22:58:26 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-07 16:48:50 +0100
commit5d65ad80b542e223c540250c27645e05239a0f33 (patch)
treeccafbd0c19814c4ef35321bc6894edacdc84bb66 /gnu/packages/autotools.scm
parentfa1e2f3d0d04a2d8e841c6d77244739c00176e9a (diff)
downloadguix-5d65ad80b542e223c540250c27645e05239a0f33.tar.gz
gnu: libtool: Use 'parallel-job-count' to get the argument for '-j'.
* gnu/packages/autotools.scm (libtool)[arguments] <check>:
  Use (parallel-job-count) instead of hand-written code.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 427c6e3113..4723d27c47 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -266,17 +266,10 @@ Makefile, simplifying the entire process for the developer.")
                      'check 'pre-check
                      (lambda* (#:key inputs #:allow-other-keys)
                        ;; Run the test suite in parallel, if possible.
-                       (let ((ncores
-                              (cond
-                               ((getenv "NIX_BUILD_CORES")
-                                =>
-                                (lambda (n)
-                                  (if (zero? (string->number n))
-                                      (number->string (current-processor-count))
-                                      n)))
-                               (else "1"))))
-                         (setenv "TESTSUITEFLAGS"
-                                 (string-append "-j" ncores)))
+                       (setenv "TESTSUITEFLAGS"
+                               (string-append
+                                "-j"
+                                (number->string (parallel-job-count))))
 
                        ;; Path references to /bin/sh.
                        (let ((bash (assoc-ref inputs "bash")))