summary refs log tree commit diff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-07 09:44:10 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-07 16:48:50 +0100
commit3246cc91858a18344a6b62272521c88dd0ec5037 (patch)
treeb839dc4d8cc70c29a481271790c2d4ddd584066d /gnu/packages/autotools.scm
parentc154e1ea81b1eb81c5716ce5a4df694fbd05c421 (diff)
downloadguix-3246cc91858a18344a6b62272521c88dd0ec5037.tar.gz
gnu: Make libtool and libltdl completely separate.
* gnu/packages/autotools.scm (libtool)[outputs]: Remove.
  [arguments]: Remove 'if' around arguments.  Add #:configure-flags.
* gnu/packages/apr.scm (apr)[inputs]: Change libtool to libltdl.
* gnu/packages/fontutils.scm (libuninameslist)[native-inputs]: Remove
  "libtool-bin".
* gnu/packages/global.scm (global): Change libtool to libltdl.
* gnu/packages/gnunet.scm (libextractor, gnunet): Likewise.
* gnu/packages/graphviz.scm (graphviz): Likewise.
* gnu/packages/libcanberra.scm (libcanberra): Likewise.
* gnu/packages/libevent.scm (libuv)[native-inputs]: Remove "bin" part
  for libtool.
* gnu/packages/mail.scm (mailutils): Change libtool to libltdl.
  (libetpan): Remove "bin" part for libtool.
* gnu/packages/mp3.scm (libmp3splt): Change libtool to libltdl.
* gnu/packages/openldap.scm (openldap): Remove "bin" part of libtool.
  Move it from 'inputs' to 'native-inputs'.
* gnu/packages/photo.scm (libgphoto2): Change libtool to libltdl.
* gnu/packages/pulseaudio.scm (pulseaudio): Likewise.
* gnu/packages/ssh.scm (guile-ssh): Remove "bin" part of libtool.
* gnu/packages/web.scm (libpsl): Likewise.
* gnu/packages/weechat.scm (weechat): Move libtool to 'native-inputs'
  and add libltdl to 'inputs'.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm49
1 files changed, 22 insertions, 27 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 0ee1d149b9..07fdde73ea 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -254,36 +254,31 @@ Makefile, simplifying the entire process for the developer.")
                      ("automake" ,automake)      ;some tests rely on 'aclocal'
                      ("autoconf" ,(autoconf-wrapper)))) ;others on 'autom4te'
 
-    ;; Separate binaries from the rest.  During bootstrap, only ltdl is
-    ;; used; not depending on the binaries allows us to avoid retaining
-    ;; a reference to the bootstrap bash.
-    (outputs '("bin"                              ;libtoolize, libtool, etc.
-               "out"))                            ;libltdl.so, ltdl.h, etc.
-
     (arguments
-     (if (%current-target-system)
-         '()                             ;no `check' phase when cross-building
-         `(;; XXX: There are test failures on mips64el-linux starting from 2.4.4:
-           ;; <http://hydra.gnu.org/build/181662>.
-           #:tests? ,(not (string-prefix? "mips64"
-                                          (or (%current-target-system)
-                                              (%current-system))))
+     `(;; Libltdl is provided as a separate package, so don't install it here.
+       #:configure-flags '("--disable-ltdl-install")
+
+       ;; XXX: There are test failures on mips64el-linux starting from 2.4.4:
+       ;; <http://hydra.gnu.org/build/181662>.
+       #:tests? ,(not (string-prefix? "mips64"
+                                      (or (%current-target-system)
+                                          (%current-system))))
 
-           #:phases (alist-cons-before
-                     'check 'pre-check
-                     (lambda* (#:key inputs #:allow-other-keys)
-                       ;; Run the test suite in parallel, if possible.
-                       (setenv "TESTSUITEFLAGS"
-                               (string-append
-                                "-j"
-                                (number->string (parallel-job-count))))
+       #:phases (alist-cons-before
+                 'check 'pre-check
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   ;; Run the test suite in parallel, if possible.
+                   (setenv "TESTSUITEFLAGS"
+                           (string-append
+                            "-j"
+                            (number->string (parallel-job-count))))
 
-                       ;; Path references to /bin/sh.
-                       (let ((bash (assoc-ref inputs "bash")))
-                         (substitute* "tests/testsuite"
-                           (("/bin/sh")
-                            (string-append bash "/bin/bash")))))
-                     %standard-phases))))
+                   ;; Path references to /bin/sh.
+                   (let ((bash (assoc-ref inputs "bash")))
+                     (substitute* "tests/testsuite"
+                       (("/bin/sh")
+                        (string-append bash "/bin/bash")))))
+                 %standard-phases)))
     (synopsis "Generic shared library support tools")
     (description
      "GNU Libtool helps in the creation and use of shared libraries, by