summary refs log tree commit diff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-01 15:24:28 +0000
committerLeo Famulari <leo@famulari.name>2017-01-05 10:43:17 -0500
commit98341757c8c45fca8d2b53f9972f5c6a32cf2c95 (patch)
tree87b8466f01a828cd965b518132c68c1fb334b9e6 /gnu/packages/autotools.scm
parentdc70626d26c23b986fa4ae9f41a1187539cd470f (diff)
downloadguix-98341757c8c45fca8d2b53f9972f5c6a32cf2c95.tar.gz
gnu: libtool: Restore ltmain.sh shebang.
This fixes <http://bugs.gnu.org/25304>

* gnu/packages/autotools.scm (libtool)[arguments]: Add new phase
'restore-ltmain-shebang'.
[native-inputs]: Add help2man.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 16ab2b8719..83018ca8ff 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -27,6 +27,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages m4)
+  #:use-module (gnu packages man)
   #:use-module (gnu packages bash)
   #:use-module (guix utils)
   #:use-module (guix packages)
@@ -301,6 +302,7 @@ Makefile, simplifying the entire process for the developer.")
     (propagated-inputs `(("m4" ,m4)))
     (native-inputs `(("m4" ,m4)
                      ("perl" ,perl)
+                     ("help2man" ,help2man) ;because we modify ltmain.sh
                      ("automake" ,automake)      ;some tests rely on 'aclocal'
                      ("autoconf" ,(autoconf-wrapper)))) ;others on 'autom4te'
 
@@ -328,6 +330,10 @@ Makefile, simplifying the entire process for the developer.")
              (substitute* "tests/testsuite"
                (("/bin/sh")
                 (string-append bash "/bin/bash")))))))))
+         (add-after 'patch-source-shebangs 'restore-ltmain-shebang
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "build-aux/ltmain.in"
+               (("^#!.*/bin/sh$") "/bin/sh")))))))
 
     (synopsis "Generic shared library support tools")
     (description