summary refs log tree commit diff
path: root/gnu/packages/avrdude.scm
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2014-07-24 11:05:43 +0000
committerLudovic Courtès <ludo@gnu.org>2014-08-11 18:38:34 +0200
commit4acd5c0f9a511f8c931baa57dda09529afcc99a9 (patch)
tree7ab792d79d79663910ae10af214a6eb9fd88a8d4 /gnu/packages/avrdude.scm
parent3a09e1d2e8ef976e5d5e35d47fcb92ae501a651e (diff)
downloadguix-4acd5c0f9a511f8c931baa57dda09529afcc99a9.tar.gz
gnu: Add AVRDUDE
* gnu/packages/avrdude.scm: New file
* gnu-system.am (GNU_SYSTEM_MODULES): Add avrdude.scm
* gnu/packages/patches/avrdude-fix-libusb.patch: New patch.
* gnu-system.am (dist_patch_DATA): Add it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/avrdude.scm')
-rw-r--r--gnu/packages/avrdude.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/avrdude.scm b/gnu/packages/avrdude.scm
new file mode 100644
index 0000000000..28456045e0
--- /dev/null
+++ b/gnu/packages/avrdude.scm
@@ -0,0 +1,58 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages avrdude)
+  #:use-module (guix licenses)
+  #:use-module (guix download)
+  #:use-module (guix packages)
+  #:use-module (gnu packages)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages bison)
+  #:use-module (gnu packages flex)
+  #:use-module (gnu packages elf)
+  #:use-module (gnu packages libusb)
+  #:use-module (gnu packages libftdi))
+
+(define-public avrdude
+  (package
+    (name "avrdude")
+    (version "6.1")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://savannah/avrdude/avrdude-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "0frxg0q09nrm95z7ymzddx7ysl77ilfbdix1m81d9jjpiv5bm64y"))
+      (patches (list (search-patch "avrdude-fix-libusb.patch")))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("libelf" ,libelf)
+       ("libusb" ,libusb)
+       ("libftdi" ,libftdi)))
+    (native-inputs
+     `(("bison" ,bison)
+       ("flex" ,flex)))
+    (home-page "http://www.nongnu.org/avrdude/")
+    (synopsis "AVR downloader and uploader")
+    (description
+     "AVRDUDE is a utility to download/upload/manipulate the ROM and
+EEPROM contents of AVR microcontrollers using the in-system programming
+technique (ISP).")
+    (license gpl2+)))