summary refs log tree commit diff
path: root/gnu/packages/axoloti.scm
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2021-04-07 14:14:56 -0400
committerEfraim Flashner <efraim@flashner.co.il>2021-04-08 11:00:05 +0300
commitbb4f47a7f614eea78a8c8a0d3e5fc55bf4e52646 (patch)
tree893b269b9f5d7bf8bfe1889a1939e7594f16aa7e /gnu/packages/axoloti.scm
parent5c9954490c81ad824900909c679900ca8ce188af (diff)
downloadguix-bb4f47a7f614eea78a8c8a0d3e5fc55bf4e52646.tar.gz
gnu: axoloti-runtime: Simplify build.
* gnu/packages/axoloti.scm (axoloti-runtime)[arguments]: Remove
unnecessary environment variable assignments in custom 'build phase.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/axoloti.scm')
-rw-r--r--gnu/packages/axoloti.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/axoloti.scm b/gnu/packages/axoloti.scm
index 3049051486..0b12e4fe29 100644
--- a/gnu/packages/axoloti.scm
+++ b/gnu/packages/axoloti.scm
@@ -147,18 +147,7 @@
          (delete 'configure)
          (replace 'build
            ;; Build Axoloti firmware with cross-compiler
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let* ((toolchain (assoc-ref inputs "cross-toolchain"))
-                    (headers   (string-append
-                                toolchain
-                                "/arm-none-eabi/include:"
-                                toolchain
-                                "/arm-none-eabi/include/arm-none-eabi/armv7e-m")))
-               (setenv "CROSS_CPATH" headers)
-               (setenv "CROSS_CPLUS_INCLUDE_PATH" headers)
-               (setenv "CROSS_LIBRARY_PATH"
-                       (string-append toolchain
-                                      "/arm-none-eabi/lib")))
+           (lambda _
              (with-directory-excursion "platform_linux"
                (invoke "sh" "compile_firmware.sh"))))
          (replace 'install