summary refs log tree commit diff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2024-04-12 09:01:01 +0100
committerChristopher Baines <mail@cbaines.net>2024-04-15 09:28:26 +0100
commit2c059863483b698c4f6f50a2ce4daaef5f1de83f (patch)
treeb585c513b8f9e4cfb7e9a2ee88654b14b6228106 /gnu/packages/backup.scm
parent6b3c90f638292f9604a221ac6dbf22234f6e4c4b (diff)
downloadguix-2c059863483b698c4f6f50a2ce4daaef5f1de83f.tar.gz
gnu: borg: Update to 1.2.8.
* gnu/packages/backup.scm (borg): Update to 1.2.8.
[arguments]: Remove a variety of workarounds that have been obviated by
changes upstream and in the Python package build tools.

Reviewed-by: Dale Mellor <guix-devel-0brg6a@rdmp.org>
Signed-off-by: Christopher Baines <mail@cbaines.net>
Change-Id: I031bb4e6ac2f562a3e387a5e815b31416367766f
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 521974f96b..5e74439bff 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -675,13 +675,13 @@ detection, and lossless compression.")
 (define-public borg
   (package
     (name "borg")
-    (version "1.2.7")
+    (version "1.2.8")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "borgbackup" version))
        (sha256
-        (base32 "06j1v4bw9jkjh6m29ns5sigmp0cslcf0cyy8rrqij11w72ijhgzn"))
+        (base32 "1aplj54x6hcyg3mnzscnwi07npy7nrws2246ss25ax6bsaq257fk"))
        (modules '((guix build utils)))
        (snippet
         #~(begin
@@ -723,18 +723,10 @@ detection, and lossless compression.")
                 (setenv "BORG_OPENSSL_PREFIX" openssl)
                 (setenv "BORG_LIBLZ4_PREFIX" lz4)
                 (setenv "BORG_LIBXXHASH_PREFIX" xxhash)
-                (setenv "BORG_LIBZSTD_PREFIX" zstd)
-                (setenv "PYTHON_EGG_CACHE" "/tmp")
-                ;; The test 'test_return_codes[python]' fails when
-                ;; HOME=/homeless-shelter.
-                (setenv "HOME" "/tmp"))))
-          ;; The tests need to be run after Borg is installed.
-          (delete 'check)
-          (add-after 'install 'check
+                (setenv "BORG_LIBZSTD_PREFIX" zstd))))
+          (replace 'check
             (lambda* (#:key inputs outputs tests? #:allow-other-keys)
               (when tests?
-                ;; Make the installed package available for the test suite.
-                (add-installed-pythonpath inputs outputs)
                 ;; The tests should be run in an empty directory.
                 (mkdir-p "tests")
                 (with-directory-excursion "tests"
@@ -749,7 +741,6 @@ detection, and lossless compression.")
                            "and not test_access_acl "
                            "and not test_default_acl "
                            "and not test_get_item_uid_gid "
-                           "and not test_non_ascii_acl "
                            "and not test_create_content_from_command "
                            "and not test_create_content_from_command_with_failed_command "
                            "and not test_create_stdin "