summary refs log tree commit diff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-07 21:31:23 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-07 22:10:17 +0100
commita5be549e393962764a9df590dc5ba6a314bfe866 (patch)
tree2e2cd6a82ec8ea3f6be9a78000b28224639b7b9a /gnu/packages/backup.scm
parent027250f1a65f5500a68687a32e444f424bda7fda (diff)
downloadguix-a5be549e393962764a9df590dc5ba6a314bfe866.tar.gz
gnu: libarchive: Remove graft for 3.3.3.
* gnu/packages/patches/libarchive-CVE-2017-14166.patch,
gnu/packages/patches/libarchive-CVE-2017-14502.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/backup.scm (libarchive): Update to 3.3.3.
[source](patches): Adjust for 3.3.3.
[replacement]: Remove field.
(libarchive-3.3.3): Remove variable.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm26
1 files changed, 5 insertions, 21 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index c312f23c1a..45b1be2413 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -197,18 +197,18 @@ backups (called chunks) to allow easy burning to CD/DVD.")
 (define-public libarchive
   (package
     (name "libarchive")
-    (replacement libarchive-3.3.3)
-    (version "3.3.2")
+    (version "3.3.3")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://libarchive.org/downloads/libarchive-"
                            version ".tar.gz"))
-       (patches (search-patches "libarchive-CVE-2017-14166.patch"
-                                "libarchive-CVE-2017-14502.patch"))
+       (patches (search-patches "libarchive-CVE-2018-1000877.patch"
+                                "libarchive-CVE-2018-1000878.patch"
+                                "libarchive-CVE-2018-1000880.patch"))
        (sha256
         (base32
-         "1km0mzfl6in7l5vz9kl09a88ajx562rw93ng9h2jqavrailvsbgd"))))
+         "0bhfncid058p7n1n8v29l6wxm3mhdqfassscihbsxfwz3iwb2zms"))))
     (build-system gnu-build-system)
     (inputs
      `(("zlib" ,zlib)
@@ -274,22 +274,6 @@ archive.  In particular, note that there is currently no built-in support for
 random access nor for in-place modification.")
     (license license:bsd-2)))
 
-(define-public libarchive-3.3.3
-  (package
-    (inherit libarchive)
-    (version "3.3.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://libarchive.org/downloads/libarchive-"
-                           version ".tar.gz"))
-       (patches (search-patches "libarchive-CVE-2018-1000877.patch"
-                                "libarchive-CVE-2018-1000878.patch"
-                                "libarchive-CVE-2018-1000880.patch"))
-       (sha256
-        (base32
-         "0bhfncid058p7n1n8v29l6wxm3mhdqfassscihbsxfwz3iwb2zms"))))))
-
 (define-public rdup
   (package
     (name "rdup")