summary refs log tree commit diff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-01 21:29:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-01 22:16:28 +0300
commit7095760cb2f91896f6a776ac37561007bd5016bf (patch)
treeee034126d2486bbce396068d6c35f463d6d73859 /gnu/packages/backup.scm
parent848f550f2c105326dc3be4033c8aaf35ec21cde4 (diff)
downloadguix-7095760cb2f91896f6a776ac37561007bd5016bf.tar.gz
gnu: libarchive: Update to 3.3.2.
* gnu/packages/backup.scm (libarchive): Update to 3.3.2.
[replacement]: Remove field.
(libarchive-3.3.2): Remove variable.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm20
1 files changed, 3 insertions, 17 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 006d00ef0c..6393c64fe9 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -184,16 +184,16 @@ backups (called chunks) to allow easy burning to CD/DVD.")
 (define-public libarchive
   (package
     (name "libarchive")
-    (replacement libarchive-3.3.2)
-    (version "3.3.1")
+    (version "3.3.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "http://libarchive.org/downloads/libarchive-"
                            version ".tar.gz"))
+       (patches (search-patches "libarchive-CVE-2017-14166.patch"))
        (sha256
         (base32
-         "1rr40hxlm9vy5z2zb5w7pyfkgd1a4s061qapm83s19accb8mpji9"))))
+         "1km0mzfl6in7l5vz9kl09a88ajx562rw93ng9h2jqavrailvsbgd"))))
     (build-system gnu-build-system)
     ;; TODO: Add -L/path/to/nettle in libarchive.pc.
     (inputs
@@ -240,20 +240,6 @@ archive.  In particular, note that there is currently no built-in support for
 random access nor for in-place modification.")
     (license license:bsd-2)))
 
-(define libarchive-3.3.2
-  (package
-    (inherit libarchive)
-    (version "3.3.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "http://libarchive.org/downloads/libarchive-"
-                           version ".tar.gz"))
-       (patches (search-patches "libarchive-CVE-2017-14166.patch"))
-       (sha256
-        (base32
-         "1km0mzfl6in7l5vz9kl09a88ajx562rw93ng9h2jqavrailvsbgd"))))))
-
 (define-public rdup
   (package
     (name "rdup")