summary refs log tree commit diff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-11-27 09:21:30 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-11-27 14:12:23 +0100
commit5f169014ecc9647cb17ee6f23b9c84fc32f1c3d0 (patch)
tree11bb44f681266ff160cef86a428639e5a7bddd6f /gnu/packages/backup.scm
parent216614a4b303492289ac11513953e47a30a68517 (diff)
downloadguix-5f169014ecc9647cb17ee6f23b9c84fc32f1c3d0.tar.gz
gnu: borg: Update to 1.1.3 [fixes CVE-2017-15914].
* gnu/packages/backup.scm (borg): Update to 1.1.3.
[arguments]: Skip ‘test_mount_hardlinks’ test.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index c83809cdf2..b1c5d4b3f8 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -466,13 +466,13 @@ detection, and lossless compression.")
 (define-public borg
   (package
     (name "borg")
-    (version "1.1.2")
+    (version "1.1.3")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "borgbackup" version))
               (sha256
                (base32
-                "00jmbfysdpsb2vcckamvsxw5n8xqh4j67diam2p0lmqzsn92syq9"))
+                "1rvn8b6clzd1r317r9jkvk34r31risi0dxfjc7jffhnwasck4anc"))
               (modules '((guix build utils)))
               (snippet
                '(for-each
@@ -521,7 +521,8 @@ detection, and lossless compression.")
                             "and not benchmark "
                             ;; These tests assume the kernel supports FUSE.
                             "and not test_fuse "
-                            "and not test_fuse_allow_damaged_files"))))))
+                            "and not test_fuse_allow_damaged_files "
+                            "and not test_mount_hardlinks"))))))
          (add-after 'install 'install-doc
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))