summary refs log tree commit diff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-06 00:18:29 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-06 05:24:17 +0100
commit38ee3d616d02b278fafc9459ac771a25ffb139b0 (patch)
treed681a785f2b1a758c9574f12f07010fd425f6cc2 /gnu/packages/backup.scm
parent2c9bc8408ee135d5f79612a5d8f34e14dbf83c7b (diff)
downloadguix-38ee3d616d02b278fafc9459ac771a25ffb139b0.tar.gz
gnu: borgmatic: Use G-expressions.
* gnu/packages/backup.scm (borgmatic)[arguments]:
Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm35
1 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 742760c0cb..c7b29fe75c 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -38,6 +38,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages backup)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix git-download)
@@ -1152,23 +1153,23 @@ compression parameters used by Gzip.")
         (base32 "0pvqlj17vp81i7saxqh5hsaxqz29ldrjd7bcssh4g1h0ikmnaf2r"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'configure
-           (lambda* (#:key inputs #:allow-other-keys)
-             ;; Set absolute store path to borg.
-             (substitute* "borgmatic/commands/borgmatic.py"
-               (("location\\.get\\('local_path', 'borg'\\)")
-                (string-append "location.get('local_path', '"
-                               (assoc-ref inputs "borg") "/bin/borg"
-                               "')")))))
-         (replace 'check
-           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
-             (when tests?
-               ;; Tests require the installed executable.
-               (setenv "PATH" (string-append (assoc-ref outputs "out") "/bin"
-                                             ":" (getenv "PATH")))
-               (invoke "pytest")))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'configure
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   ;; Set absolute store path to borg.
+                   (substitute* "borgmatic/commands/borgmatic.py"
+                     (("location\\.get\\('local_path', 'borg'\\)")
+                      (string-append "location.get('local_path', '"
+                                     (search-input-file inputs "bin/borg")
+                                     "')")))))
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     ;; Tests require the installed executable.
+                     (setenv "PATH" (string-append #$output "/bin"
+                                                   ":" (getenv "PATH")))
+                     (invoke "pytest")))))))
     (inputs
      (list borg python-colorama python-jsonschema python-requests
            python-ruamel.yaml))