summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-05-26 16:06:37 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:04 +0200
commit04af0fff52fbc433e00dc392f74030a0cc6cf362 (patch)
tree17bf0c65c3891b5b35bfc82f24ba5dfafce227f1 /gnu/packages/base.scm
parente369fa017b8e06279aeed6121ffcc2ed58270ca5 (diff)
downloadguix-04af0fff52fbc433e00dc392f74030a0cc6cf362.tar.gz
gnu: glibc-2.35: Disable C++ compiler for build.
* gnu/packages/base.scm (glibc-2.33): Move disabling the compiler from here...
(glibc-2.35): to here, and update the comment.

Change-Id: Ie2511486f0e5791929f1f48529be7cc88c9553c2
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 16a860f05c..eefff3d241 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1161,6 +1161,12 @@ with the Linux kernel.")
      (substitute-keyword-arguments (package-arguments glibc)
        ((#:configure-flags flags #~'())
         #~(cons* "--enable-crypt"
+                 ;; We do not want to use the C++ compiler, because its
+                 ;; libstdc++ is linked against a newer glibc, and so relies
+                 ;; on those newer symbols.  Pretend it doesn't link (the test
+                 ;; doesn't actually check that the compiler works with new
+                 ;; libstdc++ and older glibc).
+                 "libc_cv_cxx_link_ok=no"
                  #$flags))
        ((#:phases phases)
         ;; The C.UTF-8 fails to build in glibc 2.35:
@@ -1189,14 +1195,7 @@ with the Linux kernel.")
                         (member (basename patch)
                                 '("glibc-2.35-CVE-2023-4911.patch"
                                   "glibc-hurd-clock_gettime_monotonic.patch")))
-                             (origin-patches (package-source glibc-2.35)))))))
-    (arguments
-     (substitute-keyword-arguments (package-arguments glibc-2.35)
-       ((#:configure-flags flags ''())
-        ;; There are undefined references to pthread symbols while linking
-        ;; 'support/links-dso-program.cc'.  Since this isn't needed here, turn
-        ;; off C++ tests.
-        #~(cons "libc_cv_cxx_link_ok=no" #$flags))))))
+                             (origin-patches (package-source glibc-2.35)))))))))
 
 (define-public glibc-2.32
   (package