summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-01-06 16:30:39 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:20 +0200
commit0678ca426d9129851d7fc8ccadd6003b07d100f9 (patch)
tree16a1eb923986894008180336c4f87d3871ca29a8 /gnu/packages/base.scm
parentda26b34b0f3cf2883a4cb01e11971aad84f2ef6a (diff)
downloadguix-0678ca426d9129851d7fc8ccadd6003b07d100f9.tar.gz
Revert "gnu: coreutils: Disable 64-bit time_t on 32-bit systems."
This reverts commit 4eebb73295a8ffdaefcfb7940254ad9c18e4e5d4.

The ‘--disable-year2038’ flag appears to be unnecessary (tested on
i686-linux).  More importantly, it’s potentially harmful as it could
prevent rebuilds after year 2038 due to timestamp inconsistencies as
they wrap around, and could make the tools unusable altogether.

Change-Id: Iad828d38f84bd1824b83731ac3a3897da4b8b6d3
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm4
1 files changed, 0 insertions, 4 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 6723ca8bfb..a4a10a5964 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -466,10 +466,6 @@ used to apply commands with arbitrarily long arguments.")
                                    " test-renameatu"
                                    " test-utimensat")))
             '())
-      ,@(if (not (target-64bit?))
-          ;; Not all software is ready for 64bit time_t.
-          '(#:configure-flags (list "--disable-year2038"))
-          '())
       #:phases (modify-phases %standard-phases
                  (add-before 'build 'patch-shell-references
                    (lambda _