summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-24 16:21:45 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-30 21:43:20 +0100
commit137d957ed346547274b09ccf2383a61b5b65cce1 (patch)
tree1d926a335ca8a00430acbc2c454f8847c5ffe144 /gnu/packages/base.scm
parentc8dab7f4752133110b5aa2a9de375d812f1b9247 (diff)
downloadguix-137d957ed346547274b09ccf2383a61b5b65cce1.tar.gz
gnu: glibc: Add version 2.21.
* gnu/packages/base.scm (glibc-2.21): New variable.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index f951e28b3b..61eeba3cee 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -633,6 +633,21 @@ with the Linux kernel.")
    (license lgpl2.0+)
    (home-page "http://www.gnu.org/software/libc/")))
 
+(define-public glibc-2.21
+  ;; The old libc, which we use mostly to build locale data in the old format
+  ;; (which the new libc can cope with.)
+  (package
+    (inherit glibc)
+    (version "2.21")
+    (source (origin
+              (inherit (package-source glibc))
+              (uri (string-append "mirror://gnu/glibc/glibc-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "1f135546j34s9bfkydmx2nhh9vwxlx60jldi80zmsnln6wj3dsxf"))
+              (patches (list (search-patch "glibc-ldd-x86_64.patch")))))))
+
 (define-public glibc-locales
   (package
     (inherit glibc)