summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-08-02 22:24:02 -0400
committerLeo Famulari <leo@famulari.name>2016-08-10 15:41:21 -0400
commit9f58fe3d1c32e3f0ced065e286532a10cad1b5e3 (patch)
tree63b9a04ff14876970031ef5748cd37a34817d592 /gnu/packages/base.scm
parent2d558e31af5c8207dc4149d2f5c468c6542b99b1 (diff)
downloadguix-9f58fe3d1c32e3f0ced065e286532a10cad1b5e3.tar.gz
gnu: glibc/linux: Adjust variable name to upstream change.
* gnu/packages/base.scm (glibc/linux)[arguments]: Change
'libc_cv_localedir' to 'libc_cv_complocaledir' in #:configure-flags.
* gnu/system.scm: (operating-system-environment-variables): Remove
'GUIX_LOCPATH'.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index a476837102..4d5ab4bc41 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -527,7 +527,7 @@ store.")
             ;; Set the default locale path.  In practice, $LOCPATH may be
             ;; defined to point whatever locales users want.  However, setuid
             ;; binaries don't honor $LOCPATH, so they'll instead look into
-            ;; $libc_cv_localedir; we choose /run/current-system/locale/X.Y,
+            ;; $libc_cv_complocaledir; we choose /run/current-system/locale/X.Y,
             ;; with the idea that it is going to be populated by the sysadmin.
             ;; The "X.Y" sub-directory is because locale data formats are
             ;; incompatible across libc versions; see
@@ -535,8 +535,7 @@ store.")
             ;;
             ;; `--localedir' is not honored, so work around it.
             ;; See <http://sourceware.org/ml/libc-alpha/2013-03/msg00093.html>.
-            ;; FIXME: This hack no longer works on 2.23!
-            (string-append "libc_cv_localedir=/run/current-system/locale/"
+            (string-append "libc_cv_complocaledir=/run/current-system/locale/"
                            ,version)
 
             (string-append "--with-headers="