summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-04 06:49:29 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-07-09 12:15:52 -0400
commitd4137d84ac75edaf2739578d0868cd77dd6da43c (patch)
treeec389b86ea454880ba4494c97691314018a23c3a /gnu/packages/base.scm
parentca3757e1c2fdc1576d17239a57f0a493a47bc6dc (diff)
downloadguix-d4137d84ac75edaf2739578d0868cd77dd6da43c.tar.gz
gnu: make-glibc-locales: Adjust patch for glibc 2.29.
The patch for glibc 2.28 and earlier replaces the same content, but the context
in the patch is different enough to fail to merge.

* gnu/packages/base.scm (make-glibc-locales)[source]: Add patch.
* gnu/packages/patches/glibc-locales.patch: Adjust for glibc 2.29 and move old
file...
* gnu/packages/patches/glibc-locales-2.28.patch: ...here.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 5878cbec5e..0df40d9c50 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -999,7 +999,14 @@ with the Linux kernel.")
     (inherit glibc)
     (name "glibc-locales")
     (source (origin (inherit (package-source glibc))
-                    (patches (cons (search-patch "glibc-locales.patch")
+                    ;; The patch for glibc 2.28 and earlier replaces the same
+                    ;; content, but the context in the patch is different
+                    ;; enough to fail to merge.
+                    (patches (cons (search-patch
+                                    (if (version>=? (package-version glibc)
+                                                    "2.29")
+                                        "glibc-locales.patch"
+                                        "glibc-locales-2.28.patch"))
                                    (origin-patches (package-source glibc))))))
     (synopsis "All the locales supported by the GNU C Library")
     (description