summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-11-24 23:08:26 +0100
committerLudovic Courtès <ludo@gnu.org>2020-11-25 00:02:30 +0100
commit112982526fc0c4405002b15798522436315f5e5b (patch)
tree19820cfbb8bdfa64827cbac3e4507b3bb83aa0ae /gnu/packages/base.scm
parent04baa011e9122205009d6d5f15b8162bf6f3fb8a (diff)
downloadguix-112982526fc0c4405002b15798522436315f5e5b.tar.gz
gnu: base, commencement: Remove trailing #t from build phases.
* gnu/packages/base.scm (grep, tar, findutils)
(coreutils, coreutils-8.30, gnu-make, gnu-make-4.2)
(binutils-gold, glibc, make-glibc-locales):
(glibc/hurd-headers, tzdata): Remove trailing #t in build phases.
* gnu/packages/commencement.scm (bootar)
(gash-boot, gash-utils-boot, mes-boot):
(gzip-mesboot, gnu-make-mesboot0, bzip2-mesboot)
(bash-mesboot0, tcc-boot, diffutils-mesboot)
(patch-mesboot, sed-mesboot0, binutils-mesboot0)
(gcc-core-mesboot0, mesboot-headers, gawk-mesboot0)
(glibc-mesboot0, gcc-mesboot0, tar-mesboot)
(grep-mesboot, binutils-mesboot1, gnu-make-mesboot)
(gawk-mesboot, sed-mesboot, bash-mesboot)
(gcc-core-mesboot1, gcc-mesboot1, binutils-mesboot)
(glibc-headers-mesboot, glibc-mesboot, gcc-mesboot1-wrapper)
(gcc-mesboot, gnu-make-boot0, binutils-boot0)
(libstdc++-boot0, gcc-boot0, perl-boot0, python-boot0)
(glibc-final-with-bootstrap-bash)
(cross-gcc-wrapper, gettext-boot0, gcc-final): Remove trailing #t in
build phases.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm46
1 files changed, 15 insertions, 31 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d1febd8520..3979dbc2e7 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -119,8 +119,7 @@ command-line arguments, multiple languages, and so on.")
               (substitute* (list (string-append bin "/egrep")
                                  (string-append bin "/fgrep"))
                 (("^exec grep")
-                 (string-append "exec " bin "/grep")))
-              #t))))))
+                 (string-append "exec " bin "/grep")))))))))
    (synopsis "Print lines matching a pattern")
    (description
      "grep is a tool for finding text inside files.  Text is found by
@@ -207,8 +206,7 @@ implementation offers several extensions over the standard utility.")
                      (let ((bash (assoc-ref inputs "bash")))
                        (substitute* "src/system.c"
                          (("/bin/sh")
-                          (string-append bash "/bin/sh")))
-                       #t))))))
+                          (string-append bash "/bin/sh")))))))))
 
    ;; When cross-compiling, the 'set-shell-file-name' phase needs to be able
    ;; to refer to the target Bash.
@@ -304,8 +302,7 @@ interactive means to merge two files.")
                      (substitute* '("tests/xargs/verbose-quote.sh"
                                     "tests/find/exec-plus-last-file.sh")
                        (("#!/bin/sh")
-                        (string-append "#!" (which "sh"))))
-                     #t)))))
+                        (string-append "#!" (which "sh")))))))))
    (synopsis "Operating on files matching given criteria")
    (description
     "Findutils supplies the basic file directory searching utilities of the
@@ -377,15 +374,13 @@ used to apply commands with arbitrarily long arguments.")
                      (substitute* (find-files "gnulib-tests" "\\.c$")
                        (("/bin/sh") (which "sh")))
                      (substitute* (find-files "tests" "\\.sh$")
-                       (("#!/bin/sh") (string-append "#!" (which "sh"))))
-                     #t))
+                       (("#!/bin/sh") (string-append "#!" (which "sh"))))))
                  ,@(if (hurd-target?)
                        `((add-after 'unpack 'remove-tests
                            (lambda _
                              (substitute* "Makefile.in"
                                ;; this test hangs
-                               (("^ *tests/misc/timeout-group.sh.*") ""))
-                             #t)))
+                               (("^ *tests/misc/timeout-group.sh.*") "")))))
                        '()))))
    (synopsis "Core GNU utilities (file, text, shell)")
    (description
@@ -430,8 +425,7 @@ standard.")
                 ;; specific issue, but "env-S.pl" is not adjusted for build
                 ;; environments with long prefixes (/tmp/guix-build-...).
                 (substitute* "Makefile"
-                  (("^.*tests/misc/env-S.pl.*$") ""))
-                #t)))))))))
+                  (("^.*tests/misc/env-S.pl.*$") "")))))))))))
 
 (define-public gnu-make
   (package
@@ -463,8 +457,7 @@ standard.")
               (substitute* "src/job.c"
                 (("default_shell =.*$")
                  (format #f "default_shell = \"~a/bin/sh\";\n"
-                         bash)))
-              #t))))))
+                         bash)))))))))
    (synopsis "Remake files automatically")
    (description
     "Make is a program that is used to control the production of
@@ -498,8 +491,7 @@ change.  GNU make offers many powerful extensions over the standard utility.")
                (substitute* "job.c"
                  (("default_shell =.*$")
                   (format #f "default_shell = \"~a/bin/sh\";\n"
-                          bash)))
-               #t))))))))
+                          bash)))))))))))
 
 (define-public binutils
   (package
@@ -577,8 +569,7 @@ included.")
          (add-after 'patch-source-shebangs 'patch-more-shebangs
            (lambda _
              (substitute* "gold/Makefile.in"
-               (("/bin/sh") (which "sh")))
-             #t)))
+               (("/bin/sh") (which "sh"))))))
        ,@(substitute-keyword-arguments (package-arguments binutils)
          ; Upstream is aware of unrelocatable test failures on arm*.
          ((#:tests? _ #f)
@@ -844,9 +835,7 @@ the store.")
                          ;; "bilingual" eval/exec magic at the top of the file.
                          "")
                         (("exec @PERL@")
-                         "exec perl"))
-
-                      #t)))
+                         "exec perl")))))
 
                  (add-after 'install 'move-static-libs
                    (lambda* (#:key outputs #:allow-other-keys)
@@ -884,8 +873,7 @@ the store.")
                                      ((out) static)))
                                  (filter linker-script?
                                          (map (cut string-append slib "/" <>)
-                                              files)))
-                       #t)))
+                                              files))))))
 
                  ,@(if (hurd-target?)
                        '((add-after 'install 'augment-libc.so
@@ -894,8 +882,7 @@ the store.")
                                (substitute* (string-append out "/lib/libc.so")
                                  (("/[^ ]+/lib/libc.so.0.3")
                                   (string-append out "/lib/libc.so.0.3"
-                                                 " libmachuser.so libhurduser.so"))))
-                             #t)))
+                                                 " libmachuser.so libhurduser.so")))))))
                        '()))))
 
    (inputs `(("static-bash" ,static-bash)))
@@ -1104,8 +1091,7 @@ to the @code{share/locale} sub-directory of this package.")
                                             (string-append (dirname directory)
                                                            "/" name "."
                                                            normalized)))))
-                             locales)
-                   #t)))
+                             locales))))
              (delete 'install)
              (delete 'move-static-libs)))
          ((#:configure-flags flags)
@@ -1233,8 +1219,7 @@ command.")
                (let ((out (assoc-ref outputs "out")))
                  (close-port
                   (open-output-file
-                   (string-append out "/include/gnu/stubs.h"))))
-               #t))
+                   (string-append out "/include/gnu/stubs.h"))))))
            (delete 'build)))))))                  ; nothing to build
 
 (define-public tzdata
@@ -1288,8 +1273,7 @@ command.")
                (copy-recursively (string-append out "/share/zoneinfo-leaps")
                                  (string-append out "/share/zoneinfo/right"))
                (delete-file-recursively
-                (string-append out "/share/zoneinfo-leaps"))
-               #t)))
+                (string-append out "/share/zoneinfo-leaps")))))
          (delete 'configure))))
     (inputs `(("tzcode" ,(origin
                           (method url-fetch)