summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-08-03 20:04:37 -0400
committerMark H Weaver <mhw@netris.org>2014-08-03 21:01:27 -0400
commita092cd820b7e942d74d2745b358acd472af38b59 (patch)
treeac4ee1ada0029b083b8ec2cd58d3fe065a4cb24f /gnu/packages/base.scm
parent8ceaf72c6d50e564d6db49479e9facbb2201c3e3 (diff)
downloadguix-a092cd820b7e942d74d2745b358acd472af38b59.tar.gz
gnu: coreutils: Update to 8.23.
* gnu/packages/patches/coreutils-skip-nohup.patch: Remove.
* gnu-system.am (dist_patch_DATA): Remove coreutils-skip-nohup.patch.
* gnu/packages/patches/coreutils-dummy-man.patch: Adapt for 8.23.
* gnu/packages/base.scm (coreutils): Update to 8.23.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 005e1c000b..c61d8ce33d 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -233,17 +233,15 @@ used to apply commands with arbitrarily long arguments.")
 (define-public coreutils
   (package
    (name "coreutils")
-   (version "8.22")
+   (version "8.23")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/coreutils/coreutils-"
                                 version ".tar.xz"))
             (sha256
              (base32
-              "04hjzzv434fb8ak3hh3dyhdvg3hqjjwvjmjxqzk1gh2jh6cr8gjv"))
-            (patches (list (search-patch "coreutils-dummy-man.patch")
-                           ;; TODO: remove this patch for >= 8.23
-                           (search-patch "coreutils-skip-nohup.patch")))))
+              "0bdq6yggyl7nkc2pbl6pxhhyx15nyqhz3ds6rfn448n6rxdwlhzc"))
+            (patches (list (search-patch "coreutils-dummy-man.patch")))))
    (build-system gnu-build-system)
    (inputs `(("acl"  ,acl)                        ; TODO: add SELinux
              ("gmp"  ,gmp)))