summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-02-06 12:17:16 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-06 12:17:16 +0100
commit2c1dea853d98c16f9f15b731d7d5950e4d79b58b (patch)
tree0f0bb6e7cf72bf780b166770aca6ac49a9510ee6 /gnu/packages/base.scm
parent49a8b80da63a50a1ca3a6b8c14c21b362177dc9f (diff)
downloadguix-2c1dea853d98c16f9f15b731d7d5950e4d79b58b.tar.gz
gnu: coreutils: Move Perl to 'native-inputs'.
* gnu/packages/base.scm (coreutils): Add 'native-inputs' field.
  This should allow cross builds to have man pages, and work around this
  'dummy-man' bug:
  <http://git.yoctoproject.org/cgit.cgi/poky/plain/meta/recipes-core/coreutils/coreutils-8.22/fix-for-dummy-man-usage.patch>.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index aae50d7069..ac90b02812 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -242,12 +242,11 @@ used to apply commands with arbitrarily long arguments.")
               "04hjzzv434fb8ak3hh3dyhdvg3hqjjwvjmjxqzk1gh2jh6cr8gjv"))))
    (build-system gnu-build-system)
    (inputs `(("acl"  ,acl)                        ; TODO: add SELinux
-             ("gmp"  ,gmp)
-
-             ;; Perl is needed to run tests; remove it from cross builds.
-             ,@(if (%current-target-system)
-                   '()
-                   `(("perl" ,perl)))))
+             ("gmp"  ,gmp)))
+   (native-inputs
+    ;; Perl is needed to run tests in native builds, and to run the bundled
+    ;; copy of help2man.
+    `(("perl" ,perl)))
    (outputs '("out" "debug"))
    (arguments
     `(#:parallel-build? #f            ; help2man may be called too early