summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-28 23:46:59 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-28 23:46:59 +0100
commitf05bdc9412135f34a1c417edc203c35cd005d0d5 (patch)
treed31aa1eb3c7e20a631c037f84416036c1e86c9f0 /gnu/packages/base.scm
parent2a8d44015ff2672b7a9a2ea5054b51a83b0e934b (diff)
downloadguix-f05bdc9412135f34a1c417edc203c35cd005d0d5.tar.gz
gnu: Don't use --strip-all in cases where this is problematic.
This is a followup to 856ae5e.  See <http://hydra.gnu.org/build/180506>
for an example of build failure.

* guix/build/gnu-build-system.scm (strip): Add #:archive-strip-flags
  parameter.  Use it when (ar-file? path).
* guix/build-system/gnu.scm (gnu-build): Add #:archive-strip-flags
  parameter and pass it down.
* gnu/packages/commencement.scm (gcc-boot0)[arguments]: Add
  #:strip-flags.
* gnu/packages/base.scm (glibc)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 5bf27c9ef1..b4f4d8ee06 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -421,6 +421,9 @@ included.")
             ;; XXX: Work around "undefined reference to `__stack_chk_guard'".
             "libc_cv_ssp=no")
 
+      ;; Using '--strip-all' on crt*.o breaks them.
+      #:strip-flags '("--strip-debug")
+
       #:tests? #f                                 ; XXX
       #:phases (alist-cons-before
                 'configure 'pre-configure