summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-21 22:53:09 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-21 22:53:09 +0200
commit6162b95d21a7b75fe3753c22c7755c5d12a8302f (patch)
treefc94f9d545053b006581ce4901ec3cb588468ab5 /gnu/packages/base.scm
parentef593a103da92410192581be7a757e5654fae327 (diff)
downloadguix-6162b95d21a7b75fe3753c22c7755c5d12a8302f.tar.gz
gnu: glibc: Add dependency on Gettext, to install the message catalogs.
This fixes a bug whereby the libc.mo files were not installed, and thus
translations of libc's messages were not available.

* gnu/packages/commencement.scm (gettext-boot0): New variable.
  (glibc-final)[native-inputs]: New field.
* gnu/packages/base.scm (glibc)[native-inputs]: Add GNU-GETTEXT.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 361436157d..0c2a4a5725 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -568,9 +568,11 @@ store.")
 
    (inputs `(("static-bash" ,(static-package bash-light))))
 
-   ;; To build the manual, we need Texinfo and Perl.
+   ;; To build the manual, we need Texinfo and Perl.  Gettext is needed to
+   ;; install the message catalogs, with 'msgfmt'.
    (native-inputs `(("texinfo" ,texinfo)
-                    ("perl" ,perl)))
+                    ("perl" ,perl)
+                    ("gettext" ,gnu-gettext)))
 
    (native-search-paths
     ;; Search path for packages that provide locale data.  This is useful