summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-04-22 18:27:12 -0400
committerLeo Famulari <leo@famulari.name>2017-04-22 18:27:12 -0400
commit1524851f58d8d69f6c6e1c6406cf174083bbe82d (patch)
treed7c63b716501e4423e9f7173790a8cc4c3962935 /gnu/packages/base.scm
parent0802f3a034815576bf0e28c59c968400566b418b (diff)
parented9fb46b16cf7632e6df15c52c7183807fe5d1f9 (diff)
downloadguix-1524851f58d8d69f6c6e1c6406cf174083bbe82d.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 072f401fc3..9591d9de54 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2014, 2015 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -361,6 +362,22 @@ functionality beyond that which is outlined in the POSIX standard.")
    (license gpl3+)
    (home-page "https://www.gnu.org/software/coreutils/")))
 
+;; We add version 8.27 here for use in (gnu system) due to a time
+;; zone bug in `date' versions 8.25 - 8.26.
+;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=23035
+;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=26238
+(define-public coreutils-8.27
+  (package
+    (inherit coreutils)
+    (version "8.27")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/coreutils/coreutils-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "0sv547572iq8ayy8klir4hnngnx92a9nsazmf1wgzfc7xr4x74c8"))))))
+
 (define-public coreutils-minimal
   ;; Coreutils without its optional dependencies.
   (package