summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-05-28 15:22:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-05-28 19:08:40 +0200
commitf0c6dda640d9e7f11de987fb0b01aee09fd4ec6d (patch)
tree01496a4a71fba66891d7dcda191f28f62697333e /gnu/packages/base.scm
parent2dca204eb02835504df6846d9a543c729dc612e4 (diff)
downloadguix-f0c6dda640d9e7f11de987fb0b01aee09fd4ec6d.tar.gz
gnu: binutils: Update to 2.28.
* gnu/packages/base.scm (binutils): Update to 2.28.
[source]<patches>: Remove upstreamed patch.
[arguments]<#:configure-flags>: Remove "--disable-werror"
* gnu/packages/patches/binutils-mips-bash-bug.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 5b13a0f1de..28e0325534 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -418,17 +418,16 @@ change.  GNU make offers many powerful extensions over the standard utility.")
 (define-public binutils
   (package
    (name "binutils")
-   (version "2.27")
+   (version "2.28")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/binutils/binutils-"
                                 version ".tar.bz2"))
             (sha256
              (base32
-              "125clslv17xh1sab74343fg6v31msavpmaa1c1394zsqa773g5rn"))
+              "0wiasgns7i8km8nrxas265sh2dfpsw93b3qw195ipc90w4z475v2"))
             (patches (search-patches "binutils-ld-new-dtags.patch"
-                                     "binutils-loongson-workaround.patch"
-                                     "binutils-mips-bash-bug.patch"))))
+                                     "binutils-loongson-workaround.patch"))))
    (build-system gnu-build-system)
 
    ;; TODO: Add dependency on zlib + those for Gold.
@@ -440,10 +439,6 @@ change.  GNU make offers many powerful extensions over the standard utility.")
                           ;; Don't search under /usr/lib & co.
                           "--with-lib-path=/no-ld-lib-path"
 
-                          ;; Glibc 2.17 has a "comparison of unsigned
-                          ;; expression >= 0 is always true" in wchar.h.
-                          "--disable-werror"
-
                           ;; Install BFD.  It ends up in a hidden directory,
                           ;; but it's here.
                           "--enable-install-libbfd"