summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2021-07-10 16:49:49 -0700
committerChris Marusich <cmmarusich@gmail.com>2021-07-21 16:02:42 -0700
commit93a5e89008af440655527d03d62d4726683a89ac (patch)
tree69a56a467fc56c1d106748909b16acfaf4c92f9d /gnu/packages/base.scm
parentc3e33474b965ac1b7d91b69b026630e7c707e289 (diff)
downloadguix-93a5e89008af440655527d03d62d4726683a89ac.tar.gz
gnu: glibc-2.31: Restore patches.
Commit 87961fc965b96ac0c7a5909ac2faab2d023b5339 inadvertently modified the
patch set for glibc-2.31.  This change restores the original patch set.

Fixes: <https://bugs.gnu.org/49516>.

* gnu/packages/base.scm (glibc-2.31) [source]: Use the same patches as glibc,
but replace glibc-hurd-clock_gettime_monotonic.patch with
glibc-2.31-hurd-clock_gettime_monotonic.patch, and add
glibc-hurd-signal-sa-siginfo.patch.
* gnu/packages/patches/glibc-2.31-hurd-clock_gettime_monotonic.patch: Add it.
* gnu/packages/patches/glibc-hurd-signal-sa-siginfo.patch: Add it.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 08b1e0a686..5bb71ea3da 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -942,7 +942,21 @@ with the Linux kernel.")
               (uri (string-append "mirror://gnu/glibc/glibc-" version ".tar.xz"))
               (sha256
                (base32
-                "05zxkyz9bv3j9h0xyid1rhvh3klhsmrpkf3bcs6frvlgyr2gwilj"))))))
+                "05zxkyz9bv3j9h0xyid1rhvh3klhsmrpkf3bcs6frvlgyr2gwilj"))
+              (patches (search-patches
+                        "glibc-ldd-powerpc.patch"
+                        "glibc-ldd-x86_64.patch"
+                        "glibc-dl-cache.patch"
+                        "glibc-hidden-visibility-ldconfig.patch"
+                        "glibc-versioned-locpath.patch"
+                        "glibc-allow-kernel-2.6.32.patch"
+                        "glibc-reinstate-prlimit64-fallback.patch"
+                        "glibc-supported-locales.patch"
+                        "glibc-hurd-clock_t_centiseconds.patch"
+                        "glibc-2.31-hurd-clock_gettime_monotonic.patch"
+                        "glibc-hurd-signal-sa-siginfo.patch"
+                        "glibc-hurd-mach-print.patch"
+                        "glibc-hurd-gettyent.patch"))))))
 
 (define-public glibc-2.30
   (package