summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-01 16:37:37 +0100
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-24 23:31:33 +0100
commit974c42a70a12f0c4ed298c2c8dab3f154338de58 (patch)
tree332f3ff956005c347d667d0dd4c8313483ce7258 /gnu/packages/base.scm
parent9b943db357ad63b7a3d063c658b1f557697ef0fa (diff)
downloadguix-974c42a70a12f0c4ed298c2c8dab3f154338de58.tar.gz
gnu: glibc: Add clock patches for the Hurd.
* gnu/packages/patches/glibc-hurd-clock_t_centiseconds.patch: New file.
* gnu/packages/patches/glibc-hurd-clock_gettime_monotonic.patch: New file.
* gnu/local.mk (dist_patch_DATA): Update them.
* gnu/packages/base.scm (glibc): Use them.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index c3298b3cec..1b7a834ac8 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -612,7 +612,9 @@ the store.")
                                      "glibc-versioned-locpath.patch"
                                      "glibc-allow-kernel-2.6.32.patch"
                                      "glibc-reinstate-prlimit64-fallback.patch"
-                                     "glibc-supported-locales.patch"))))
+                                     "glibc-supported-locales.patch"
+                                     "glibc-hurd-clock_t_centiseconds.patch"
+                                     "glibc-hurd-clock_gettime_monotonic.patch"))))
    (build-system gnu-build-system)
 
    ;; Glibc's <limits.h> refers to <linux/limit.h>, for instance, so glibc