summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-20 18:13:53 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-21 23:17:20 +0100
commitcdba91486a60bbba727d843707322f98f8286124 (patch)
tree1245ae6980426f5a9d40209a16f6eb03679d3d5f /gnu/packages/base.scm
parent99406d9b684ec60384dc29d850905dd517fb9790 (diff)
downloadguix-cdba91486a60bbba727d843707322f98f8286124.tar.gz
gnu: make: Update to 4.3.
* gnu/packages/patches/make-impure-dirs.patch: Adjust for renamed files.
* gnu/packages/patches/make-glibc-compat.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/base.scm (gnu-make): Update to 4.3.
[source](uri): Change to ".gz" tarball.
[source](patches): Remove obsolete.
[arguments]: Remove #:configure-flags.  Adjust for renamed files.
[inputs]: Change from GUILE-2.0 to GUILE-3.0.
* gnu/packages/commencement.scm (gnu-make-boot0)[arguments]: Add #:configure-flags.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 9f8130be50..45f6cf79ba 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -360,31 +360,27 @@ functionality beyond that which is outlined in the POSIX standard.")
 (define-public gnu-make
   (package
    (name "make")
-   (version "4.2.1")
+   (version "4.3")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/make/make-" version
-                                ".tar.bz2"))
+                                ".tar.gz"))
             (sha256
              (base32
-              "12f5zzyq2w56g95nni65hc0g5p7154033y2f3qmjvd016szn5qnn"))
-            (patches (search-patches "make-impure-dirs.patch"
-                                     "make-glibc-compat.patch"))))
+              "06cfqzpqsvdnsxbysl5p2fgdgxgl9y4p7scpnrfa8z2zgkjdspz0"))
+            (patches (search-patches "make-impure-dirs.patch"))))
    (build-system gnu-build-system)
    (native-inputs `(("pkg-config" ,pkg-config)))  ; to detect Guile
-   (inputs `(("guile" ,guile-2.0)))
+   (inputs `(("guile" ,guile-3.0)))
    (outputs '("out" "debug"))
    (arguments
-    '(;; Work around faulty glob detection with glibc 2.27.  See
-      ;; <https://lists.nongnu.org/archive/html/bug-make/2017-11/msg00027.html>.
-      #:configure-flags '("make_cv_sys_gnu_glob=yes")
-      #:phases
+    '(#:phases
       (modify-phases %standard-phases
         (add-before 'build 'set-default-shell
           (lambda* (#:key inputs #:allow-other-keys)
             ;; Change the default shell from /bin/sh.
             (let ((bash (assoc-ref inputs "bash")))
-              (substitute* "job.c"
+              (substitute* "src/job.c"
                 (("default_shell =.*$")
                  (format #f "default_shell = \"~a/bin/sh\";\n"
                          bash)))