summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-03 12:23:33 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-03 14:36:11 +0200
commite393586161dd0b8814bbb88e9212deffa171687f (patch)
tree8290cb45f5ddd4158323d164ed032a2d1c702f82 /gnu/packages/base.scm
parent2ae71b746bd7265735cb50b2dd93a09ef45f9f38 (diff)
downloadguix-e393586161dd0b8814bbb88e9212deffa171687f.tar.gz
gnu: coreutils: Use upstream's fix for 'tail'.
* gnu/packages/patches/coreutils-racy-tail-test.patch: Remove.
* gnu-system.am (dist_patch_DATA): Adjust accordingly.
* gnu/packages/base.scm (coreutils)[source]: Replace this patch with
  upstream's fix for 'tail'.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 99f60d1400..1b4233420f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -251,7 +251,14 @@ used to apply commands with arbitrarily long arguments.")
              (base32
               "0w11jw3fb5sslf0f72kxy7llxgk1ia3a6bcw0c9kmvxrlj355mx2"))
             (patches
-             (list (search-patch "coreutils-racy-tail-test.patch")))))
+             (list (origin
+                     (method url-fetch)
+                     (uri "http://git.savannah.gnu.org/cgit/coreutils.git/\
+patch/?id=3ba68f9e64fa2eb8af22d510437a0c6441feb5e0")
+                     (sha256
+                      (base32
+                       "1dnlszhc8lihhg801i9sz896mlrgfsjfcz62636prb27k5hmixqz"))
+                     (file-name "coreutils-tail-inotify-race.patch"))))))
    (build-system gnu-build-system)
    (inputs `(("acl"  ,acl)                        ; TODO: add SELinux
              ("gmp"  ,gmp)                        ;bignums in 'expr', yay!