summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-08 16:22:11 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-08 21:45:43 +0200
commit425799cb45473616fc884fd23c413ac4f3027729 (patch)
tree4c4c335207d508bd6aa017e34a8ba6c3495f3e73 /gnu/packages/base.scm
parent6d8c1a5e2302d8c1223ea9a4da44975931bad383 (diff)
downloadguix-425799cb45473616fc884fd23c413ac4f3027729.tar.gz
gnu: glibc@2.30: Fix build error.
* gnu/packages/base.scm (glibc-2.30)[native-inputs]: New field.
[source]: Use "glibc-skip-c++.patch".
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 695a056265..9c9808fcfa 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -965,13 +965,19 @@ with the Linux kernel.")
   (package
     (inherit glibc)
     (version "2.30")
+    (native-inputs
+     ;; This fails with a build error in libc-tls.c when using GCC 10.  Use an
+     ;; older compiler.
+     (modify-inputs (package-native-inputs glibc)
+       (prepend gcc-8)))
     (source (origin
               (inherit (package-source glibc))
               (uri (string-append "mirror://gnu/glibc/glibc-" version ".tar.xz"))
               (sha256
                (base32
                 "1bxqpg91d02qnaz837a5kamm0f43pr1il4r9pknygywsar713i72"))
-              (patches (search-patches "glibc-ldd-x86_64.patch"
+              (patches (search-patches "glibc-skip-c++.patch"
+                                       "glibc-ldd-x86_64.patch"
                                        "glibc-CVE-2019-19126.patch"
                                        "glibc-hidden-visibility-ldconfig.patch"
                                        "glibc-versioned-locpath.patch"