summary refs log tree commit diff
path: root/gnu/packages/bash.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-09-03 11:12:28 +0300
committerAlex Kost <alezost@gmail.com>2015-09-06 12:33:21 +0300
commitf24931d841bc7879708cdeec93f9b79cee3dc670 (patch)
tree30144c5289afe29ca4f8b9f8b31329460552f837 /gnu/packages/bash.scm
parent1de0afd5a5f6e1603df414909a3d9c35689aa94e (diff)
downloadguix-f24931d841bc7879708cdeec93f9b79cee3dc670.tar.gz
gnu: bash-light: Rename to bash-minimal.
* gnu/packages/bash.scm (bash-light): Rename to ...
  (bash-minimal): ...this.
  (static-bash): Use it.
* gnu/packages/make-bootstrap.scm (%bash-static): Use it.
Diffstat (limited to 'gnu/packages/bash.scm')
-rw-r--r--gnu/packages/bash.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index fcfa337fab..180c64e872 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -214,10 +214,10 @@ without modification.")
      (license gpl3+)
      (home-page "http://www.gnu.org/software/bash/"))))
 
-(define-public bash-light
+(define-public bash-minimal
   ;; A stripped-down Bash for non-interactive use.
   (package (inherit bash)
-    (name "bash-light")
+    (name "bash-minimal")
     (inputs '())                                ; no readline, no curses
     (arguments
      (let ((args `(#:modules ((guix build gnu-build-system)
@@ -242,7 +242,7 @@ without modification.")
 (define-public static-bash
   ;; Statically-linked Bash that contains nothing but the 'bash' binary and
   ;; 'sh' symlink, without any reference.
-  (let ((bash (static-package bash-light)))
+  (let ((bash (static-package bash-minimal)))
     (package
       (inherit bash)
       (name "bash-static")