summary refs log tree commit diff
path: root/gnu/packages/bdw-gc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-03-30 19:32:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-03-30 19:41:35 +0300
commit1bd8dadbe46e3ca0559ef46ae2c9a3a008a88027 (patch)
tree14670d6f676cc8b3dea37a3ef6aa216b9ec181f4 /gnu/packages/bdw-gc.scm
parentdbc96f451c9bd4c14fbe99454abbcb1c90d66285 (diff)
downloadguix-1bd8dadbe46e3ca0559ef46ae2c9a3a008a88027.tar.gz
gnu: libgc: Fix building on powerpc-linux.
* gnu/pakcages/bdw-gc.scm (libgc)[arguments]: When building for
powerpc-linux add a make-flag to not protect virtual-dirty bits.
Diffstat (limited to 'gnu/packages/bdw-gc.scm')
-rw-r--r--gnu/packages/bdw-gc.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index b788c3288e..5ff4649716 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -64,12 +64,17 @@
                                  (%current-target-system)))
                #~("--disable-gcj-support")
                #~())))
-     (if (target-ppc64le?)
-       (list #:make-flags
-             ;; This is a known workaround upstream.
-             ;; https://github.com/ivmai/bdwgc/issues/479
-             #~(list "CFLAGS_EXTRA=-DNO_SOFT_VDB"))
-       '())))
+     (cond
+       ((target-ppc64le?)
+        (list #:make-flags
+              ;; This is a known workaround upstream.
+              ;; https://github.com/ivmai/bdwgc/issues/479
+              #~(list "CFLAGS_EXTRA=-DNO_SOFT_VDB")))
+       ((target-ppc32?)
+        (list #:make-flags
+              ;; Similar to above.
+              #~(list "CFLAGS_EXTRA=-DNO_MPROTECT_VDB")))
+       (else '()))))
    (native-inputs (list pkg-config))
    (propagated-inputs
     (if (%current-target-system)