summary refs log tree commit diff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-05-28 09:13:38 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-28 11:36:02 +0200
commitc82b374979ce6d3c2883b9cc6842711779903f15 (patch)
treecc27868fbe4fbef855d3fcb6a1b88fda1dbfeebb /gnu/packages/benchmark.scm
parent90e1f9cbe1de92346cf609d3f2b60fee8e1358b0 (diff)
downloadguix-c82b374979ce6d3c2883b9cc6842711779903f15.tar.gz
gnu: intel-mpi-benchmarks: Remove top-level reference to 'openmpi'.
This circular dependency could lead to "unbound variable" errors when
running 'guix show openmpi' or similar.

* gnu/packages/benchmark.scm (intel-mpi-benchmarks/openmpi): Inline code
formerly in 'intel-mpi-benchmarks' procedure.
(intel-mpi-benchmarks): Remove.
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index a75663a1f8..681408a4e6 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
-;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 malte Frank Gerdes <malte.f.gerdes@gmail.com>
 ;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -126,13 +126,9 @@ is to write a job file matching the I/O load one wants to simulate.")
     (license (list license:gpl2 license:gpl2+ license:bsd-2
                    license:public-domain))))
 
-;; Parameterized in anticipation of m(va)pich support
-(define (intel-mpi-benchmarks mpi)
+(define-public intel-mpi-benchmarks/openmpi
   (package
-    (name (string-append "intel-mpi-benchmarks"
-                         (if (string=? (package-name mpi) "openmpi")
-                             ""
-                             (string-append "-" (package-name mpi)))))
+    (name "intel-mpi-benchmarks")
     (version "2019.6")
     (source (origin
               (method git-fetch)
@@ -154,7 +150,7 @@ is to write a job file matching the I/O load one wants to simulate.")
                   #t))))
     (build-system gnu-build-system)
     (inputs
-     `(("mpi" ,mpi)))
+     `(("openmpi" ,openmpi)))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -194,9 +190,6 @@ Efficiency of the MPI implementation.
 @end itemize")
     (license license:cpl1.0)))
 
-(define-public intel-mpi-benchmarks/openmpi
-  (intel-mpi-benchmarks openmpi))
-
 (define-public imb-openmpi
   (deprecated-package "imb-openmpi" intel-mpi-benchmarks/openmpi))